Go Down

Topic: New R3 from Amazon = avrdude: stk500_recv(): programmer is not responding (Read 877 times) previous topic - next topic

stopshinal

I just upgraded to the lastest Arduino 1.0.3.
I'm on Mac 10.7.5
I dont believe I need to add any new drivers.

Ran an Uno just fine a year ago on this computer. Just bought this on Jan 2nd:

http://www.amazon.com/Arduino-Rev-3-Uno-R3/dp/B006H06TVG/ref=sr_1_1?ie=UTF8&qid=1357450019&sr=8-1&keywords=arduino+r3

When I plugged it into my USB I get the red ON light and a steady red pin 13 light.

When I upload a sketch I get some green flashes from the rx/tx lights, pin 13 led dances a bit, then it goes solid. In the console i'm given this:

avrdude: stk500_recv(): programmer is not responding

The fact I can get the rx/tx lights to dance when I upload a sketch makes me think one thing - but no matter how I troubleshoot it I cannot make any progress. Help widely appreciated!

westfw

The pin13 LED should not be "steady on."
Also, I think it's supposed to be yellow, and the power LED should be green.  Red indicators are apparently supposed to be avoided in "real products" except for errors.
So you apparently have a counterfeit (also matches the other comments on amazon.)  And it's semi-official amazon ("sold by mp3car store, fullfilled by amazon") and broken, so it should fall under their return policy (whether or not it's counterfeit, I guess.  (You don't have to complain that it doesn't seem to be real, only that it doesn't work.))

westfw

(one wonders in the case of the better made and more blatantly "pretending/offending" clones whether the intermediate vendor ("mp3car store") actually thinks they're selling real Arduinos, that they somehow got a "too good to be true" deal on ("these were from the first manufacturing run and are discounted because of the burn marks on the hand soldering before they got the process down pat."  Right.)   I doubt it; I don't think I've ever seen a real Arduino from a reputable vendor that was significantly cheaper than $30...)

James C4S

If it has a red LED and sold on Amazon, it is a knock-off / clone.  So whatever it is called (Uno or R3 or whatever), doesn't matter.

If you're going to keep it, one thing to try is changing the board type to Duemilanove since many clones have the Duemilanove bootloader.  You can also carefully look at the chip near the USB port and determine if it is a ATmega8u2 or ATmega16u or a FTDI chip.  If it is a FTDI, well then you'll need drivers.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

stopshinal

I'm getting a greenhouse setup tomorrow - so I dont have time to return it if I can make this work. But thanks for the heads up everyone - now I know to never buy anything under 30$

It's an ATmega16u chip.

Tried many of the other boards - still no luck.

Thanks for the help guys - any last ideas?

stopshinal

Problem was with the included USB cord. I used my own and everything worked absolutely fine. Rawr. Cheap USB cords and fake arduinos.

Go Up