Go Down

Topic: actionneur linéaire firgelli (Read 705 times) previous topic - next topic

carouch

Bonjour,
J'essaie un peu tous les moteurs comme vous avez pu le constater dans mes messages...
Je commence à comprendre leur fonctionnement!!
Par contre, je bloque sur le dernier que je viens d'acheter, c'est un firgelli L12-50-100-6R.
J'utilise une arduino Artmega 2560 et comme ce moteur marche comme un servo moteur, je mets comme programme dans l'IDE :
#include <Servo.h>
Servo myservo;
void setup()
{ myservo.attach(9); }
void loop() {
myservo.write(20);
   delay(4000);
myservo.write(100);
   delay(4000);
   


Mais ça ne marche pas !!
De temps en temps il bouge mais dès que je veux changer les angles la carte ne veut plus communiquer et elle met que le port com est déjà utilisé.
ça fait deux jours que je suis non stop sur ça, alors si vous avez une petite idée, je suis preneuse!!!
Merci d'avance et très bonne journée.

Artouste


Bonjour,
J'essaie un peu tous les moteurs comme vous avez pu le constater dans mes messages...
Je commence à comprendre leur fonctionnement!!
Par contre, je bloque sur le dernier que je viens d'acheter, c'est un firgelli L12-50-100-6R.
J'utilise une arduino Artmega 2560 et comme ce moteur marche comme un servo moteur, je mets comme programme dans l'IDE :
#include <Servo.h>
Servo myservo;
void setup()
{ myservo.attach(9); }
void loop() {
myservo.write(20);
   delay(4000);
myservo.write(100);
   delay(4000);
   


Mais ça ne marche pas !!
De temps en temps il bouge mais dès que je veux changer les angles la carte ne veut plus communiquer et elle met que le port com est déjà utilisé.
ça fait deux jours que je suis non stop sur ça, alors si vous avez une petite idée, je suis preneuse!!!
Merci d'avance et très bonne journée.



bonjour
question de base avec les servos = le servo est alimenté par quoi pour la puissance
alimentation dediée ou par la carte arduino ?

carouch

Le servo est alimenté par la carte arduino, j'ai aussi essayé de l'alimenter par un générateur continu 6V et ça n'a pas marché !!
Peut être que je l'ai mal branché...

Artouste


Le servo est alimenté par la carte arduino, j'ai aussi essayé de l'alimenter par un générateur continu 6V et ça n'a pas marché !!
Peut être que je l'ai mal branché...

faire des photos "lisibles" du branchement  :smiley-mr-green:

Go Up