Pages: [1]   Go Down
Author Topic: Can't upload to UNO  (Read 593 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I can't upload my programs to my uno board.  I was attempting to connect it to my iRobot Roomba and I think it short circuited the uno.  Any suggestions?
Logged

Offline Offline
Faraday Member
**
Karma: 68
Posts: 2854
The last thing you did is where you should start looking.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try a new AtMaega chip with bootloader
Logged

The way you have it in your schematic isn't the same as how you have it wired up! That goes for me too.

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think the problem is the RX pin for the AtMega 16u2.  If so, how would I try a new AtMega chip?
Logged

Offline Offline
Faraday Member
**
Karma: 68
Posts: 2854
The last thing you did is where you should start looking.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If it is that, you need a new PCB
Logged

The way you have it in your schematic isn't the same as how you have it wired up! That goes for me too.

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 137
Posts: 6805
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
the problem is the RX pin for the AtMega 16u2.
Why do you think that?
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 69
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I can't upload my programs to my uno board.  I was attempting to connect it to my iRobot Roomba and I think it short circuited the uno.  Any suggestions?

I think we might be able to use some details as to how it was wired up. Right now there's not enough information to make a good guess yet.
Logged

Pages: [1]   Go Up
Jump to: