Pages: [1]   Go Down
Author Topic: Using two SPI devices, neither of which uses a slave select  (Read 238 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm trying to use the RedBearLab BLE shield with the RePaper e-ink dev kit from adafruit. So far they aren't playing nicely together. I'm using an Arduino Mega. The BLE shield says pins 50-53 (50 (MISO), 51 (MOSI), 52 (SCK), and 53 (SS)) are 'unavailable'. I got that information here http://redbearlab.com/bleshield/ However, this post https://redbearlab.zendesk.com/entries/22420923-Which-Arduino-pins-are-used- makes it seem like another SPI device can be used. They also claim that the BLE shield doesn't use SS (slave select). The repaper kit also uses pins 50, 51, and 52, but not 53 (slave select). I found that information here http://learn.adafruit.com/repaper-eink-development-board/wiring-the-mega I'm not sure how I can use these two SPI devices together if neither of them use a slave select. Is there a way to use these two devices together? Can repaper or the BLE shield use SS? Thanks!
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 148
Posts: 6104
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

They both appear to have slave selects, but it may be difficult to wire both together on the same Arduino.
The RedBear uses D8 and D9 (slave select?). The RePaper also uses D8 (slave select?) and D9.
Here is the schematic for the RePaper. Pin 19 on the 20 pin connector that you connect to the Arduino appears to be the slave select.
http://repaper.org/doc/downloads/epd_ref_circuit_v05.pdf
Logged

Pages: [1]   Go Up
Jump to: