Pages: [1]   Go Down
Author Topic: piloter hub USB  (Read 281 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bjr,

je suis une petite quiche en électronique et j'ai le problème suivant : je souhaiterais commander avec arduino l'alimentation d'un hub USB alimenté par une alimentation ATX (PC) et non pas par la prise USB.

l'alimentation ATX est branchée sur un relais 230V et est piloté (sans problèmes) par arduino (digitalWrite (9, HIGH)).

j'ai un hub USB branché dessus (entre autre) et je souhaiterais allumer/éteindre cette "branche" sans pour autant éteindre les autres. J'ai donc pensé à un transistor 2N3904 (parce que j'en avais en stock).

voir http://www.ecs.umass.edu/ece/m5/tutorials/multiple_LEDs_tutorial.html

donc, l'émetteur au GND. Les GND d'arduino et de l'alimentation ATX mise en commun. Une résistance de 1Ko sur la pin de l'arduino qui va servir d'interrupteur, relié à la base. et enfin (pour les essais) je prends une led avec sa résistance que je branche sur le collecteur et de l'autre côté sur le +5V de l'ATX.

pour le sketch j'ai fais un équivalent de "blink" en y rajoutant la broche 13 (led de la carte, pour bien montrer que le programme n'est pas en cause)

Tout me semble correct... sauf que ça marche pas. J'ai testé ma led qui est OK. je me trompe quelque part mais j'arrive pas à comprendre où (?????)(p'taaaaiiiinnn)

d'abord, quelqu'un peut-il valider le shéma du lien (je n'utilise qu'une seule led, mais la résistance est adaptée à la led ?)

si vous avez des questions, suggestions, début de suggestions, n'importe quoi.... je suis preneur. (j'y connais rien aux transistors !)

Merci d'avance,
cactus68100
Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5213
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bjr,

je suis une petite quiche en électronique et j'ai le problème suivant : je souhaiterais commander avec arduino l'alimentation d'un hub USB alimenté par une alimentation ATX (PC) et non pas par la prise USB.

l'alimentation ATX est branchée sur un relais 230V et est piloté (sans problèmes) par arduino (digitalWrite (9, HIGH)).

j'ai un hub USB branché dessus (entre autre) et je souhaiterais allumer/éteindre cette "branche" sans pour autant éteindre les autres. J'ai donc pensé à un transistor 2N3904 (parce que j'en avais en stock).

voir http://www.ecs.umass.edu/ece/m5/tutorials/multiple_LEDs_tutorial.html

donc, l'émetteur au GND. Les GND d'arduino et de l'alimentation ATX mise en commun. Une résistance de 1Ko sur la pin de l'arduino qui va servir d'interrupteur, relié à la base. et enfin (pour les essais) je prends une led avec sa résistance que je branche sur le collecteur et de l'autre côté sur le +5V de l'ATX.

pour le sketch j'ai fais un équivalent de "blink" en y rajoutant la broche 13 (led de la carte, pour bien montrer que le programme n'est pas en cause)

Tout me semble correct... sauf que ça marche pas. J'ai testé ma led qui est OK. je me trompe quelque part mais j'arrive pas à comprendre où (?????)(p'taaaaiiiinnn)

d'abord, quelqu'un peut-il valider le shéma du lien (je n'utilise qu'une seule led, mais la résistance est adaptée à la led ?)

si vous avez des questions, suggestions, début de suggestions, n'importe quoi.... je suis preneur. (j'y connais rien aux transistors !)

Merci d'avance,
cactus68100
bonsoir
quel est la tension dispo sur le "5V" allant vers le HUB apres le transistor ? si ça se trouve elle est hors specifs et le hub... hub pas !   smiley-mr-green
attention aussi, il me semble que dans certains cas il y a de la negociation de courant, mais ça ne devrait pas etre le cas là
Logged

Pages: [1]   Go Up
Jump to: