Go Down

Topic: Ardu-Aquarium Controller v. 3.3.1 (Read 77206 times) previous topic - next topic

Brunello

una domanda...
ma i collegamenti su quel LCD....
sono saldati, o hai infilato il cavetto nel foro e ci hai fatto un nodo ?

leouz

caro Simon,
I condensatori vari non è che sono da 100nf anzichè 100uf ?

simon77blitz

Inanzi tutto Buonasera a voi tutti
e come sempre vi rinnovo i miei ringraziamenti per l'aiuto che mi state dando.
Ho seguito il consiglio di Rici e ho ricominciato a studiarmi di nuovo lo schema filo per filo e voi non ci crederete e neanche io ma ora
si accende tutto , ma ho ancora un problemino con LCD  se regolo il primo trimmer quello che sta dalla parte sinistra riesco solo a visualizzare qualche lettera e numero ma il resto non si vede ,ho provato a regolare anche l'altro trimmer ma quello sembra che non funziona praticamente non cambia niente vi volevo chiedere ma la resistenza del secondo trimmer praticamente la devo collegare nel pin centrale e poi al negativo?
poi sapete che può essere perchè lo schermo fa cosi?
grazie

simon

pespes

Domanda: ma per far funzionare la scheda relè l'abbinamento PCF8574 - 74HC540 è proprio così indispensabile?
Lo chiedo perchè ho provato a collegare la scheda relè direttamente al PCF8574 e funziona perfettamente.
Al contrario se ci metto di mezzo il 74HC540 non mi ritrovo i 5v nelle uscite Y

riciweb

@Simon,
Direi che i tuoi pcf non siano versione A, lancia lo sketch a questo indirizzo http://playground.arduino.cc/Main/I2cScanner ed alimentando un pcf alla volta, annota gli indirizzi dei pcf del display, dei tasti e della scheda relé, quindi li cambi nel mio sketch e lo ricarichi,
Fammi sapere.

@Pespes,
Che scheda relé usi?
Riccardo

simon77blitz

scusami Rici non riesco a capire che vuol dire che i pcf non siano versione A?

riciweb

Riccardo

pespes



@Pespes,
Che scheda relé usi?



Uso quella che hai publicato tu, presa da ardupower

simon77blitz

ho controllato i miei pcf e sopra c è scritto pcf8574ap / a4p521.102  /  kn612393
quindi dovrebbero essere quelli giusti ma non riesco ancora a capire il perchè sullo schero non riesco a visualizzare tutte le scritte

riciweb

Ciao, nella foto non si capisce bene, ma sembra che i cavi sul display non siano saldati, probabilmente hai dei falsi contatti...
Non vedo altre spiegazioni.

Rici
Riccardo

riciweb



@Pespes,
Che scheda relé usi?

Uso quella che hai publicato tu, presa da ardupower


Il Pcf, non fornisce molta corrente in uscita, dalle prove che ho potuto fare io, mi sono accorto che quanto attivavo più uscite contemporaneamente, non riusciva ad attivate tutti i darlington dell'ULN2803, ecco perché ho dovuto aggiungere il 74HC540, tra l'altro su prezioso consiglio di Brunello, se torni indietro nelle pagine di questo topic trovi tutto.

Rici
Riccardo

simon77blitz

Buonasera a tutti
pultroppo non sono ancora riuscito a risolvere il problema del LCD praticamente mi visualizza solo un pezzetto di scritta per il resto solo quadratini,lo ho provato da solo e sono riuscito a farllo funzionare,
qualcuno avrebbe qualche idea da cosa potrebbe dipendere
grazie

simon

riciweb

Ciao,
Dall'immagine non sembra ci sia un problema di regolazione del contrasto, ne di regolazione della luminosità, in più escludo un problema software, visto che già gira senza problemi su diverse bread, se sei assolutamente sicuro dei collegamenti, l'unica cosa che rimane è che il tuo LCD sia difettoso, provane un'altro se puoi, male che vada hai un display pronto per futuri progetti  :)
Ciao
Riccardo

leo72

OT: Credo che il suo giusto posto sia questo.  ;)

Michele Menniti


OT: Credo che il suo giusto posto sia questo.  ;)

a patto che Simon77 non continui a postare lo stesso problema su due Topic 8)
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Go Up