Go Down

Topic: Arduino IDE doesn't start (Read 111 times) previous topic - next topic

PastasLover

Hello,
recently, i downloaded the arduino IDE and it worked perfectly...
But, a day, I download 1.6.4 version and when I tried to start it, the start icon appeared, it print "loading configuration", "initializeing packages" and... it crashed. I tried 3/4 times again but the same thing at each try. I thank "it's a bug with the 1.6.4" so I uninstalled it and I install again the 1.6.3 (who worked perfectly) and the same thing happened ! my laptop is an old dell with Windows XP. The processor is a 1.6Ghz 500mo of ram Pentium Intel.
Can you help me ?

Federico Fissore

Sure. Can you please try starting the IDE from the command prompt: use arduino_debug.exe. Before terminating, it will print an error message. Please paste it here
Have you upgraded the Yún? If you've just got it, then it needs to be upgraded! Check out the tutorial at http://is.gd/1jUPNF

PastasLover

#2
May 08, 2015, 03:48 pm Last Edit: May 08, 2015, 03:51 pm by PastasLover
Code: [Select]
Loading configuration...
Initializing packages...
com.fasterxml.jackson.core.JsonParseException: Unexpected character ('<' (code 60)): expected a valid value (number, String, array, object, 'true', 'false' or 'null')
at [Source: java.io.FileInputStream@17f23d9; line: 1, column: 2]
       at com.fasterxml.jackson.core.JsonParser._constructError(JsonParser.java:1369)
       at com.fasterxml.jackson.core.base.ParserMinimalBase._reportError(ParserMinimalBase.java:532)
       at com.fasterxml.jackson.core.base.ParserMinimalBase._reportUnexpectedChar(ParserMinimalBase.java:453)
       at com.fasterxml.jackson.core.json.UTF8StreamJsonParser._handleUnexpectedValue(UTF8StreamJsonParser.java:2278)
       at com.fasterxml.jackson.core.json.UTF8StreamJsonParser._nextTokenNotInObject(UTF8StreamJsonParser.java:779)
       at com.fasterxml.jackson.core.json.UTF8StreamJsonParser.nextToken(UTF8StreamJsonParser.java:665)
       at com.fasterxml.jackson.databind.ObjectMapper._initForReading(ObjectMapper.java:2926)
       at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(ObjectMapper.java:2873)
       at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:2080)
       at cc.arduino.contributions.libraries.LibrariesIndexer.parseIndex(LibrariesIndexer.java:79)
       at cc.arduino.contributions.libraries.LibrariesIndexer.parseIndex(LibrariesIndexer.java:68)
       at processing.app.BaseNoGui.initPackages(BaseNoGui.java:625)
       at processing.app.Base.<init>(Base.java:256)
       at processing.app.Base.guardedMain(Base.java:198)
       at processing.app.Base.main(Base.java:113)


It's all the error message.

Federico Fissore

It looks like the download json file is corrupted. Please open folder %APPDATA%\Arduino15 and delete all .json files
Have you upgraded the Yún? If you've just got it, then it needs to be upgraded! Check out the tutorial at http://is.gd/1jUPNF

PastasLover

#4
May 08, 2015, 04:14 pm Last Edit: May 08, 2015, 04:17 pm by PastasLover
Alleluia :D
Thanks you very much for your help

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy