Pages: [1]   Go Down
Author Topic: R: Road to solve the delay on the Arduino IDE  (Read 4346 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Edison Member
*
Karma: 38
Posts: 1232
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The old original topic was http://arduino.cc/forum/index.php/topic,46977.0.html

Thanks to eried, to neophob (http://neophob.com/2011/05/serial-library-rxtx-v2-2pre5/) and to the guys and girls working on RXTX (the piece of software we use to make the pc communicate with our boards) I've managed to fix the "tools" menu delay issue.

I need someone volunteering and testing the fix. Instructions below:

Attached you can find a .zip which contains 2 files. You have to overwrite the existing ones with the ones attached. BEFORE you do so, back them up: copy them somewhere else, so you can restore them if bad things happen.

One file is "RXTXComm.jar": it is a multiplatform file, everyone of you has it under folder "lib" in the folder where you have installed your arduino ide.

The other file is specific to your operating system: I've managed to make the linux 32 and 64 bit and windows versions. Mac versions will soon follow.
If you have a 32bit or 64bit linux, copy file librxtxSerial.so from folder linux32 or linux64 into folder "lib" (right next RXTXComm.jar)
If you have windows, copy file windows/rxtxSerial.dll into the folder where you have installed your arduino ide (right next arduino.exe)

Run the ide and report back: is everything running as usual? If you were experiencing the tools menu delay: has it disappeared?

Thank you in advance

Federico
« Last Edit: January 15, 2013, 06:20:03 am by federicofissore » Logged

Have you upgraded the Yún? If you've just got it, then it needs to be upgraded! Check out the tutorial

Offline Offline
Edison Member
*
Karma: 38
Posts: 1232
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've updated the zip file to include the mac specific lib: it's only for Intel based macs

* rxtx.zip (244.94 KB - downloaded 146 times.)
Logged

Have you upgraded the Yún? If you've just got it, then it needs to be upgraded! Check out the tutorial

Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 23
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The IDE seems to be running as usual after replacing the JAR file as well as the DLL, but the delay in the tool menu still seems to persist.
Logged

Offline Offline
Edison Member
*
Karma: 38
Posts: 1232
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you tried latest IDE release? (1.5.4)
Logged

Have you upgraded the Yún? If you've just got it, then it needs to be upgraded! Check out the tutorial

0
Offline Offline
Newbie
*
Karma: 0
Posts: 21
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Speaking of an updated IDE, I just opened a ticket over the GitHub repo with a new proposed design and some missing features:

https://github.com/arduino/Arduino/issues/1590

Rob
Logged

Offline Offline
Edison Member
*
Karma: 38
Posts: 1232
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Very nice!
Logged

Have you upgraded the Yún? If you've just got it, then it needs to be upgraded! Check out the tutorial

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm running OSX and recently upgraded my IDE from 1.0.5 to 1.5.7 to use the Yun and am experiencing the delay issues both on startup and when selecting the Tools menu.  I also tried older 1.5.x builds and had the same issue.  I don't have any problems using 1.0.5 and an Uno. 

I attempted to follow the instructions but haven't been able to figure out where to place the updated files.  They don't appear to already exist in the lib folder when I look through the Arduino package in OSX.  I searched my computer and couldn't find a file with RXTX other than the ones I downloaded using the links from this thread.  As an alternative I tried to place the files in the Extensions folder in HD/Library/Java/Extensions but to no avail.  I also tried turning off Bluetooth which had been suggested in other threads. 

Any suggestions would be greatly appreciated. 
Logged

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 133
Posts: 6753
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I thought that the original issue was window only, and is old.
A "delay" problem with Yun on Mac is probably a new and different problem; try starting a new thread.
Logged

Pages: [1]   Go Up
Jump to: