Go Down

Topic: Mac OSX 10.8 and 10.7 Serial Port in Tools menu greyed out (Read 473 times) previous topic - next topic

pk47

I have a new Uno Rev 3 board that has the Serial Port selection greyed out but only when running on a Mac. On a Windows XP machine it works perfectly.
As soon as I click the Tools menu I get this error message "java.lang.ClassCastException: gnu.io.RXTXCommDriver cannot be cast to gnu.io.CommDriver thrown while loading gnu.io.RXTXCommDriver[/color]"

In Terminal I can see the port as "crw-rw-rw-  1 root  wheel   18,  28 Jan 11 14:45 /dev/tty.usbmodemfa1211". I'm running Arduino version 1.0.3
I have tried different USB ports and different USB cables all with same result.

I have no idea where to go from here, any help would be appreciate.

ericklil

I have exactly the same issue on my Mac Pro Early 2008 10.8.2. However on my MacBook Air it works fine.....

Erick

James C4S

Check to see if there is a difference in java versions between the two macs.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy