Go Down

Topic: Why is my LCD not working? no contrast? (Read 845 times) previous topic - next topic

plasmaninjaa

Hi!
I bought this LCD: http://www.engineersgarage.com/electronic-components/16x2-lcd-module-datasheet
and am trying to get it to work with my arduino.

I have followed the instructions found in this video: http://www.youtube.com/watch?v=oIiDseJO4dM

and am trying to run this program (a progress bar): http://jeremyblum.com/wp-content/uploads/2011/07/Episode-13-Arduino-Programs.zip

although I am not getting anything from the LCD when I turn it on or try to run the program.

I think the problem might be with the contrast, are you supposed to see something on the screen when you start it up even if your not programming the LCD?
I hooked up a 5k pot on the VEE, ground, and +ve but still am not seeing anything.

Here is a picture of my whole setup: http://imgur.com/KpwPz,XD2Ij#1
and here is a picture of the back of the LCD: http://imgur.com/KpwPz,XD2Ij#0

thanks for any help! :)

dhenry


plasmaninjaa


How do you get data to your lcd?



what do you mean? Isnt the data being sent through d4-7?

I found that I am having the same problem as this person in this post: http://arduino.cc/forum/index.php/topic,18381.0.html

however there is no answer in that post...

dhenry

Quote
Isnt the data being sent through d4-7?


Is it?

floresta

#4
Jan 12, 2013, 02:34 am Last Edit: Jan 12, 2013, 02:38 am by floresta Reason: 1
Quote
How do you get data to your lcd?

I think he meant 'How do you get power to your LCD'.  

Edit: No - he didn't.  His original comment stands.

Don

Go Up