Go Down

Topic: Cavo USB, problema con la tensione (Read 4 times) previous topic - next topic

leo72

Inoltre manca l'alimentazione al pin AVCC, non c'è la R di pull-up sul pin di reset. Il pin 8 di massa non è collegato..

Michele Menniti


Inoltre manca l'alimentazione al pin AVCC, non c'è la R di pull-up sul pin di reset. Il pin 8 di massa non è collegato..

sì, ma lui l'aveva detto e ne avete già parlato, no? tutte queste esatte osservazioni migliorano il circuito ma certamente non spiegano il problema del sovraccarico o cortocircuito. Io temo che il problema sia sulla millefori, non è proprio il massimo da vedere, però è quasi impossibile riuscire a capirci qualcosa e soprattutto a vedere un eventuale corto.
Però mi pare che nessuno ti abbia suggerito di misurare con un tester i pin 5V e GND della tua scheda, OVVIAMENTE scollegata dal PC per vedere se c'è un bel corto o almeno una resistenza bassissima, l'hai fatta questa verifica?
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leo72



Inoltre manca l'alimentazione al pin AVCC, non c'è la R di pull-up sul pin di reset. Il pin 8 di massa non è collegato..

sì, ma lui l'aveva detto e ne avete già parlato, no? tutte queste esatte osservazioni migliorano il circuito ma certamente non spiegano il problema del sovraccarico o cortocircuito.

No, aspetta. Lui aveva detto di non aver collegato l'alimentazione all'ADC.
Ma se vedi lo schema, ha collegato VCC sul pin 7 ma NON la massa sul pin 8, che invece ha collegato al pin 22. Manca la tensione positiva sul pin 20 (AVCC).
:*
Insomma ha fatto un po' di intrecci sulle linee di alimentazione.

Michele Menniti

ricordi i test che feci un annetto fa dopo una lunga discussione con Astro??? i due GND sono assolutamente in comune ed io sono riuscito ad alimentare e far funzionare il micro sia con un GND che con l'altro e addirittura col solo AVCC con un GND qualsiasi, il problema non è lì a mia memoria
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leo72


ricordi i test che feci un annetto fa dopo una lunga discussione con Astro??? i due GND sono assolutamente in comune ed io sono riuscito ad alimentare e far funzionare il micro sia con un GND che con l'altro e addirittura col solo AVCC con un GND qualsiasi, il problema non è lì a mia memoria

Anch'io feci dei test e fui in grado di far funzionare l'ADC su uno standalone senza connettere la coppia AVCC/GND dei pin 20/22 però visto che siamo ad esaminare i problemi, era giusto specificare che quella connessione non è corretta.
Poi va visto anche il codice: se lui pensa di accendere tutti i led contemporaneamente, può darsi che mandi in blocco l'alimentazione da porta USB (e qui si torna al problema dell'assenza dei dati sulle R dei LED).
Poi c'è la questione dei corti che hai sollevato tu: quelle saldature effettivamente non sono il massimo. Dovrebbe mettersi di "buzzo buono" (come si dice dalle mie parti  ;) ) col tester e verificare se c'è una qualche conduzione parassita.

Go Up