Go Down

Topic: Cavo USB, problema con la tensione (Read 5099 times) previous topic - next topic

leo72

Per i consumi credo che volesse dire "si accendono uno un piano alla volta", difatti poi parla di 9 led.

Michele Menniti


Per i consumi credo che volesse dire "si accendono uno un piano alla volta", difatti poi parla di 9 led.

sì, va bene, l'importante era escludere un consumo spropositato, comunque è la seconda parte della frase che :smiley-eek: ma comunque non ha importanza, ci sono troppi fattori incogniti
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

veigh

Ma ciò che non mi spiego è che prima di fare questo progetto, ho fatto un altro cubo con gli stessi collegamenti e pezzi (resistenze, led, transistor) uguali. Perfino la resistenza sulla base del transistor, cioè non l'ho messa nemmeno sul primo progetto. L'unica differenza è che usavo la scheda Arduino, invece qui uso solo il micro. Quindi facciamo una serie di tentativi: il GND è comune? o devo saldarlo su entrambi i pin? Il VCC va solo sul pin 7 oppure anche su AVCC devo farlo arrivare? Benchè non utilizzi gli analogici.

veigh

#33
Jan 22, 2013, 04:16 pm Last Edit: Jan 22, 2013, 04:22 pm by veigh Reason: 1
Ho constatato che se punto col tester il pin 7 del micro (VCC) e sul catodo dei led (quindi anche sul collettore dei transistor) vi è un'intensità NEGATIVA di 6-7 A. Possibile?  :smiley-eek: non potevano essere solo 100mA??

P.S. Azz di male in peggio. Facendo altre prove, ho scoperto che puntando il tester sullo zoccolo del micro (SENZA il micro), mi da una tensione di -5V, e ovviamente invertendo le punte (cioè mettendo la punta positiva sul GND e la negativa sul VCC) ho una tensione di 5V. Inoltre con punta positiva su VCC e negativa su GND mi da un'intensità di -85mA (che teoricamente dovrebbe essere di quei 100mA per l'enumerazione, solo che sono negativi). Il mistero di complica. Non è che la usb ha i fili al contrario?!

leo72


Ho constatato che se punto col tester il pin 7 del micro (VCC) e sul catodo dei led (quindi anche sul collettore dei transistor) vi è un'intensità NEGATIVA di 6-7 A. Possibile?  :smiley-eek: non potevano essere solo 100mA??


La corrente non si misura in parallelo ma in serie.

Quote

P.S. Azz di male in peggio. Facendo altre prove, ho scoperto che puntando il tester sullo zoccolo del micro (SENZA il micro), mi da una tensione di -5V, e ovviamente invertendo le punte (cioè mettendo la punta positiva sul GND e la negativa sul VCC) ho una tensione di 5V. Inoltre con punta positiva su VCC e negativa su GND mi da un'intensità di -85mA (che teoricamente dovrebbe essere di quei 100mA per l'enumerazione, solo che sono negativi). Il mistero di complica. Non è che la usb ha i fili al contrario?!

Non è che hai invertito tu qualcosa?  ;)

veigh


Non è che hai invertito tu qualcosa?  ;)


Filo rosso -> corrente, filo nero -> massa. Almeno questa cosa la so  :D da quando avevo 5 anni xD

leo72



Non è che hai invertito tu qualcosa?  ;)


Filo rosso -> corrente, filo nero -> massa. Almeno questa cosa la so  :D da quando avevo 5 anni xD

Allora è colpa dei Maya  ;)

veigh

Dai mo la pigliamo a barzelletta la cosa xD che devo fare secondo te? Non so più cosa provare

Michele Menniti


Ho constatato che se punto col tester il pin 7 del micro (VCC) e sul catodo dei led (quindi anche sul collettore dei transistor) vi è un'intensità NEGATIVA di 6-7 A. Possibile?  :smiley-eek: non potevano essere solo 100mA??

questo è un test senza senso ed un risultato impossibile, comincio ad avere il dubbio che tu col tester non abbia quel minimo di dimestichezza per poterci ricavare un minimo di info decenti, ecco perché parlo di troppe incognite.
Quote

P.S. Azz di male in peggio. Facendo altre prove, ho scoperto che puntando il tester sullo zoccolo del micro (SENZA il micro), mi da una tensione di -5V, e ovviamente invertendo le punte (cioè mettendo la punta positiva sul GND e la negativa sul VCC) ho una tensione di 5V. Inoltre con punta positiva su VCC e negativa su GND mi da un'intensità di -85mA (che teoricamente dovrebbe essere di quei 100mA per l'enumerazione, solo che sono negativi). Il mistero di complica. Non è che la usb ha i fili al contrario?!

appunto, di male in peggio, l'USB NON PUO' AVERE i fili al contrario, semplicemente perché è una porta, è molto più probabile che abbia tu invertito i due poli + e -. SE SEI SICURO della tua prova salda al contrario i due fili; il micro non penso si sia guastato, facilmente ti parte tutto e risolviamo
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

veigh


appunto, di male in peggio, l'USB NON PUO' AVERE i fili al contrario, semplicemente perché è una porta, è molto più probabile che abbia tu invertito i due poli + e -. SE SEI SICURO della tua prova salda al contrario i due fili; il micro non penso si sia guastato, facilmente ti parte tutto e risolviamo

A questo aveva già risposto leo, le misure vanno fatte in serie e non in parallelo. Col tester so fare le cose più semplici. Avendole studiate a scuola, ho una conoscenza più teorica che pratica. Se sei sicuro che la porta usb non può che essere collegata bene, perché mi consigli di saldare al contrario? Io sto solo chiedendo come devo fare per cercare di risolvere.

leo72

Scusa, ma dalla porta USB non può esserci una tensione invertita. E' uno standard, la tensione positiva esce sulla linea + e massa è su -. Se fosse come dici, collegando un qualunque dispositivo a quella porta, lo bruceresti.
A meno che tu non abbia già bruciato quella porta con corti... siamo sicuri che essa funzioni correttamente?

Tu come prelevi la tensione dalla porta? Usi una presa USB? Hai sfilacciato un cavo?
Non è che hai invertito i collegamenti tra la presa o il cavo ed il tuo circuito?

Per quello che ne so anche i puntali del tester possono essere inverti, controlla magari il problema della confusione e nel tester. Ma se non dovessero essere invertiti misura la tensione direttamente su i fili della usb, che dai colori sembrano corretti, il rosso è positivo e il nero è GND, ma potrebbe non essere così.

PS: per il micro avrei preferito usare uno zoccolo, così da poterlo estrarre e sostituire.
Ciao.
AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

Michele Menniti

credo che il micro sia su zoccolo, visto che parla di aver misurato senza....
@ veigh, vogliamo provare  a fare una cosa con un minimo di logica, altrimenti qui facciamo la festa dei quattro rincoglioniti e staremo a parlare giorni e giorni senza combinare niente. Premesso che non te la devi prendere quando ti si dice una parola in più, in fondo siamo qui per aiutarti, ma tu le devi dare le informazioni invece di fartele tirare con le tenaglie.
Oltretutto se ti si suggerisce una cosa ed invece di farla stai a porre domande, non ne usciamo più, o ti fidi ed esegui subito ciò che ti si consiglia o non ti fidi a vai avanti per la tua strada e amici come prima, non è che oltre a darti i consigli ti dobbiamo pure convincere. Quindi se ti va proseguiamo senza obiezioni, se non ti va per me possiamo fermarci qui.
La prima prova da fare è verificare il TESTER:
1 - inserisci i cavetti: rosso nella presa "V" e nero nella presa "GND" o col simbolo della messa a terra.
2 - imposta la portata 2VDC o 20VDC.
3 - misura una qualsiasi batteria, che però sia abbastanza carica, quelle scariche fanno cose strane.
Mi dici cosa leggi?

Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

veigh

Ma nessuno se la prende Michè! Tutte le informazioni che so ve le dico, non è mica un segreto di stato, solo che non so quali informazioni sono utili e quali no. Comunque il tester ha sempre funzionato bene, e ora l'ho riprovato: su una batteria AAA segna 1.2 V, così come è scritto sulla batteria stessa. Se vi può essere utile il tester è questo: http://www.casconeshop.it/?wpsc-product=pinza-amperometrica-con-tester-e-sonda-termica-valex . Detto questo, @Mauro, sì uso uno zoccolo, molto più comodo e soprattutto non rischio di bruciare il micro, data la mia inesperienza nella saldatura. Ed infine @leo, ho usato un cavo usb recuperato da un mouse (che a suo tempo funzionava bene). Quindi è impossibile che abbia usato male la porta perchè ho preso il cavo e ho collegato il filo rosso al pin VCC e il nero al GND.

leo72

Fatte le prove coi puntali, ed assodato che il tester funziona.... proviamo il cavetto e basta.
Stacca il circuito e poi misura la tensione sui fili che escono dal cavetto che hai recuperato. Se fin lì i 5V sono dove devono essere, allora il problema è sul tuo circuito e passiamo a quello.

Go Up