Go Down

Topic: Another Mega2560 that does not upload. (Read 567 times) previous topic - next topic

rbid

Hello,

My son is in a group that does robotics in a bunch of projects. When I was helping them, other team had their Arduino Mega2560 that stopped to upload.
I tried to help them, but I could not reach any success, they have replaced the Mega with a second one, and also it did not work, only the third one worked.


  • The first one it may be because some servo was using too much current and stopped to work after the student pressed "burn-butloader" by mistake, and the board was not identified by windows any more... (even changing drivers).

  • The second one, does not finish uploading.



I took both boards home to play with them, when the scenario is: (with the board that does not finish uploading)


  • Windows7 64bit

  • Correct drivers for the Mega, the mega gets identified as it should be (COM port 3, Arduino Mega 2560 R3)

  • The fist time you upload a sketch, it compiles OK and apparently starts to upload it as in the image below:


    Screenshot

  • The second time, the COM port is in use and all fails till I reset the board, disconnect the USB and connect it to a different port on my laptop.

  • Every time the Mega board is powered, the led blinks once (next to pin 13)

  • Running the loop-back test fails (http://arduino.cc/forum/index.php/topic,73748.0.html)



Any hint?

For the second board, after this one works, I guess a new bootloader should be burned in.

I'm relatively new to the Arduino world. (I have a Due that my son is using in his team)

Thanks in advance.

Go Up