Go Down

Topic: LeoStick upload program error (Read 1 time) previous topic - next topic


I am currently trying to upload a program to a LeoStick that has been verified compiled with no problems and I get the following error
avrdude : stk500_getsync() : not in sync : resp= 0x30

I am using Arduino 1.0.1 software to write the sketch and to upload to the LeoStick
Operating system is Windows XP
I have done the following
    Download the usbdriver from www.freetronics.com/usbdriver
    Inserted the LeoStick into the usb port. The LeoStick was successfully installed and allocated comport 3
    Download both LeoStick definitions from www.freetronics.com/leostick (LeoStick_v1_0 and Leostick_v2_0)
    From preferences I got the Sketchbook location and created folder called "hardware". Put LeoStick_v1_0 and Leostick_v2_0 folders into the folder called "hardware"
    From taskbar select tools then Serial Port selected com3 from Board selected Freetronics Leostick v2.0
    From file selected Upload. The program Verified and compiled with the above error
    Then went to Upload using programmer (I dont know difference) The same result
    Then I changed the Board to Freetronics Leostick v1.0  same result
    Tried pressing reset button on Leostick board and uploading again. Same Result
    Check that the comport 3 was not being used by another device. Only Leostick has comport 3 allocated to it.

   Went and purchase another stick thinking it maybe faulty but same result
   Went and used another computer (Windows 7 operating system) same error result
   This computer also allocated com3.
   It does seem that the computer is not communicating with the Leostick as the Leds dont seem to change ie(one stays blue and the other flashes red
   I presume when the LeoStick device is installed it sets up the serial communication. ie baud rate 9600 etc

   I would very much appreciate any suggestions as I have run out of ideas other than setting up a Linux system

    Thanks in advance Ian


You should really be asking Freetronics. It's their product, and they do say:
Any firmware or Arduino Leonardo compatible support should not be considered to be final release firmware or in any way an official Arduino. Don't hassle the Arduino team with support or requests related to this board: they're solely our responsibility.


For LeoStick support, please visit: http://forum.freetronics.com/viewforum.php?f=27


For LeoStick support, please visit: http://forum.freetronics.com/viewforum.php?f=27

True but how many times do real staff actually help here vs members of the public who also spend a lot of their own personal time to help people with THEIR product.

As far as I'm concerned, the path goes both ways.

To answer the OP's original Question.

Programmer > AVRISP MKII
Board > FreeTronics LEoStick, you'll have 2 boards here, try both..

on doing so, hit the reset button each of your tries, as once your firmware
is running, it changes com port.. you have a brief window, reset, upload
within a second, but don't hold it down or you can't upload.

having said that, it should auto-reset anyway/

Go Up