Go Down

Topic: Collegamento scheda a relè 16 canali (Read 6681 times) previous topic - next topic

amacbr

Buongiorno, vi scrivo per chiedervi conferma che la scheda seguente ha bisogno di 12V di alimentazione per comandare i relè:
http://www.ebay.it/itm/16-canali-channel-5V-Rele-Relay-Board-Module-AVR-PIC-ARM-DSP-MCU-/170915329028#ht_3009wt_1397
Ha bisogno anche della 5V da arduino, giusto?

Grazie
"Cosi non si va avanti..." disse il gambero

tonid

A me pare che ti servano solo i 12 volt e poi i 5v se li ricava dallo step-down che ha a bordo.
Dovresti solo fornire tramite gli I/0 del chip che userai per comandarla....Ti dice che bastano 15/20 mA perchè credo che vai a pilotare gli optoisolatori (quindi dei led) ed il transistor in uscita dell'optoisolatore andrà a pilotare gli integrati che credo siano degli ULNxxxx. 

amacbr

quindi non dovrò collegare i pin 5V della scheda con i pin 5V di arduino? la scheda ne ha 2 di pin 5V
"Cosi non si va avanti..." disse il gambero

tonid

Non penso prorio...
Mettici solo il 12volt e poi come al solito usa i pin di arduino per comandare gli noptoisolatori..

PaoloP

Sicuramente devi collegare il GND col GND di Arduino.

amacbr

sono riuscito a provare la scheda, funziona senza collegare i 5V. Ho collegato solo i pin delle uscite e il GND. La scheda funziona al contrario, con un'uscita 0 il rele si eccita, quando l'uscita passa a 1 il rele si diseccita.
Maggiorni informazioni le potete trovare qua http://arduino.cc/forum/index.php/topic,144199.0.html
Mi servirebbe piu disponibilita di digital output e stavo pensando di prendere arduino due, ma poi ho letto questo warning
Unlike other Arduino boards, the Arduino Due board runs at 3.3V. The maximum voltage that the I/O pins can tolerate is 3.3V. Providing higher voltages, like 5V to an I/O pin could damage the board.
da cui mi sembra di capire che quella scheda rele non è utilizzabile con arduino due. Se davvero fosse cosi prenderò arduino mega.
"Cosi non si va avanti..." disse il gambero

PaoloP

#6
Jan 29, 2013, 01:59 pm Last Edit: Jan 29, 2013, 02:01 pm by PaoloP Reason: 1
Puoi sempre usare 2 PCF8574 --> http://www.laurtec.it/brief-notes/programmazione-pic/125-bn0013-it-pcf8574-i2c-io-expander-libreria-ed-utilizzo
Li comandi con 2 pin (SDA e SCL) e risolvi il problema.
Se vuoi una soluzione già pronta --> http://www.ebay.it/itm/PCF8574-IO-Expansion-Board-I2C-bus-to-8-bit-parallel-/250846403731#ht_1311wt_952

Lucailvec

perchè cose così complesse uno spartano multiplexer ? :smiley-roll:

PaoloP


perchè cose così complesse uno spartano multiplexer ? :smiley-roll:

Si.
hai un modello da suggerire?  ;)

Lucailvec

scusa demux decoder errore mio XD
in ogni caso è perfetto visto che è ideato appositamente con l'uscita abilitata a livello basso poi non so magari ho capito male  :smiley-sad-blue:
http://www.datasheetcatalog.org/datasheets/208/337810_DS.pdf

amacbr

sto cercando un modo, un'altra scheda rele, per eccitare i rele con uscite a 1, altrimenti non mi sento sicuro di collegare anche la salita degli avvolgibili perche se spengo arduino mi si energizzerebbe sia salita che discesa e farei un corto.
Però altre schede a rele, basterebbero 12 rele, non riesco a trovarle.
Con un demux decoder riesco a pilotarle correttamente?
"Cosi non si va avanti..." disse il gambero


bigjohnson

#12
Feb 08, 2013, 02:58 pm Last Edit: Feb 08, 2013, 03:00 pm by bigjohnson Reason: 1
Per evitare di dare tensione contemporaneamente alla salita e alla discesa ti consiglio lo schema dall'immagine allegata, così se entrambi i relè sono chiusi la tapparella sale e basta, se lo inverti scende.

MauroTec

Quote
sto cercando un modo, un'altra scheda rele, per eccitare i rele con uscite a 1, altrimenti non mi sento sicuro di collegare anche la salita degli avvolgibili perche se spengo arduino mi si energizzerebbe sia salita che discesa e farei un corto.
Però altre schede a rele, basterebbero 12 rele, non riesco a trovarle.
Con un demux decoder riesco a pilotarle correttamente?


Devi usare un transistor per ogni ingresso della scheda, lo schema è lo stesso identico a quello consigliato per collegare un relè ad arduino, cerca nel playground.

In questo modo risolvi il comportamento anomalo allo spegnimento di arduino e per eccitare il rele devi fornire un segnale HIGH, non LOW come adesso.

Ciao.
AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

superzaffo

Scusami, ma normalmente quelle schede sono fatte per essere usate sia con un eventuale H=close e sia per H=open.
Prova ad invertire i cavi nella morsettiera (a parte il comune) NC->NO o viceversa così dovresti avere con H l' attivazione del tuo carico
ciao

Go Up