Go Down

Topic: Glass Kiln Control (Read 1 time) previous topic - next topic

GlennD

Sep 18, 2011, 04:59 am Last Edit: Jan 11, 2012, 01:26 am by GlennD Reason: 1
I have been asked several times for the code for this control.  Thought this might be the best place for it.
The story is my wife bought a used manual kiln.  They are a pain in the butt to baby sit while fusing glass. I am a cheap skate and did not want to spend the $150 $200 bucks for a pre-made one. At that time I had just found the Arduino platform. I purchased one as well as the buttons and LCD from Sparkfun did some reading and found this shieldhttp://store.ryanjmclaughlin.com/interface-boards/assembled/nulzg  then got to work.



It took me a couple of weeks to figure it all out. A few missteps and very hot kiln for the first trial run, but got it pretty well ironed out.

It uses a Potter & Brumfield Relay 92P7D52-12 run by a TIP102 soldered into the shield. I don't have a schematic just kind of did it as I went along.
I think I left enough comments to follow and help someone understand what is going on.
Don't be to harsh first Arduino code still learning.

Glenn
"Some cause happiness wherever they go;
others, whenever they go.." - Oscar Wilde

pwillard

Bummer... Attachments no longer work...  :-(

RPCoyle

are you using the MAX31855 chip the older MAX6675. I have built kiln controllers with both and I am having stability problems with the MAX31855 chip that I didn't have with the MAX6675. the 31855 displays rolling temperature oscillations around a correct average that increase as the temperature gets higher. it seems like the fluctuations are around 10% of the actual temperature.   Also I see random scrambled readings. 

I have also used AD595 chips, and have had no problem... nice and quite. Have you run into this problem while you were shaking out your system?

I hope you can get the bad links back on line, I'd like to see your code.

I use a laptop to control and log the the results of the run graphically. If you are interested in trying it I'll send you the app and the Arduino code I am using.

pYro_65


Bummer... Attachments no longer work...  :-(


Check back another time, seems like a server error, the file should be available once fixed.

Go Up