Pages: [1]   Go Down
Author Topic: Keywords not Highlighting Brown or Orange  (Read 1445 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 62
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have written a library called motor. Which complies and is recognized in the Arduino libary.

It is at: arduino-1.0.3-windows\arduino-1.0.3\libraries\Motor

I have these three files in there:
keywords.txt
Motor.cpp
Motor.h

when i open a sketch and include motor the key words i have specied in the keyword.txt doc do not highlight. Any ideas why?

my txt

Motor KEYWORD1
setpPin KEYWORD2
setnPin KEYWORD2
idle KEYWORD2
foward KEYWORD2
backward KEYWORD2
update KEYWORD2
test KEYWORD2
getTime KEYWORD2
Logged

Chile
Offline Offline
Edison Member
*
Karma: 35
Posts: 1251
Arduino rocks?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you post your library to check it out?

Also, you can use Documents/Arduino/Libraries.
Logged

My website: http://ried.cl

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 211
Posts: 13469
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

IIRC there was something with the keywords.txt file, the separators should be all TAB chars and no other white-space char.
also you need to restart ALL IDE's after changing lib files.

(The tip from eried to use Documents/Arduino/Libraries is important! Think what will happen when you upgrade the Arduino to 1.xXX)
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Pages: [1]   Go Up
Jump to: