Go Down

Topic: Arduino Nano works only one time and then the computer does not recognize it (Read 3 times) previous topic - next topic

szangvil

I got a few Arduino Nanos (clones from China). I installed the FTDI drivers. I connected the first one to my computer - all is fine. I uploaded my sketch and it runs with no problems.
I then connected the same one to the computer and all of the sudden, windows will not recognize the device! It shows up as unknown device. What the hell? I rebooted, uninstalled and re-installed the drivers but that did not solve it. No matter what I do, windows will recognize it any more. Tried it on another computer - same results.
I bought 20 of those and already tried 4 of them with the same result - first time I connect it, it's all good - it shows up as a serial port. Next time I connect it, windows will not recognize it!
I tried without uploading a sketch i.e., just connect it to the PC, see it in the device manager, unplug it and plug it again - same result, second time it will not be recognized!

Has anyone encountered this before?

PaulS



spycatcher2k

If you have a meter - check the components around the ftdi, if all measures OK then plug in to usb and chase the voltages. You can send them here to be tested/repaired (may not be worth it for P&P).
Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

szangvil


Go Up