Go Down

Topic: Can't compile blink example with Mega2560 [FIXED] (Read 542 times) previous topic - next topic


Jan 18, 2013, 02:18 am Last Edit: Jan 18, 2013, 02:59 pm by jacubillo Reason: 1
Hello everyone,

I was given an Arduino Mega2560 as a birthday present and I haven't been able to use because it always gives an error when compiling code for this specific board. My UnoR3 works fine but as soon as I change the board to Mega2560 and try to compile even the blink example I get this error:

/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:91:41: error: attempt to use poisoned "SIG_USART0_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:101:15: error: attempt to use poisoned "SIG_USART0_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:132:15: error: attempt to use poisoned "SIG_USART1_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:145:15: error: attempt to use poisoned "SIG_USART2_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:158:15: error: attempt to use poisoned "SIG_USART3_RECV"

I'm using a Fedora17 laptop. All updates. And the Arduino 1.0.1 IDE.

Googling the error it seems it happened before and was supposed to have been fixed but I still get it.

First time posting an error/bug. Please let me know if there is a better place for this :)

- Juan


Latest Linux IDE is 1.03. I'd install that first.

Coding Badly



Thank you for the help.

Tried the solution from the link and it works perfect now.

Also installed newest 1.0.3 IDE and it also works out of the box. I was using 1.0.1 because that's what yum installs.

All set now! :)

Go Up

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

shortcuts: alt+s submit/post or alt+p preview