Pages: [1]   Go Down
Author Topic: Can't compile blink example with Mega2560 [FIXED]  (Read 487 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello everyone,

I was given an Arduino Mega2560 as a birthday present and I haven't been able to use because it always gives an error when compiling code for this specific board. My UnoR3 works fine but as soon as I change the board to Mega2560 and try to compile even the blink example I get this error:

/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:91:41: error: attempt to use poisoned "SIG_USART0_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:101:15: error: attempt to use poisoned "SIG_USART0_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:132:15: error: attempt to use poisoned "SIG_USART1_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:145:15: error: attempt to use poisoned "SIG_USART2_RECV"
/usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:158:15: error: attempt to use poisoned "SIG_USART3_RECV"

I'm using a Fedora17 laptop. All updates. And the Arduino 1.0.1 IDE.

Googling the error it seems it happened before and was supposed to have been fixed but I still get it.

First time posting an error/bug. Please let me know if there is a better place for this smiley

 - Juan
« Last Edit: January 18, 2013, 08:59:22 am by jacubillo » Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 69
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Latest Linux IDE is 1.03. I'd install that first.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 198
Posts: 12753
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


http://arduino.cc/forum/index.php/topic,92364.msg814661.html#msg814661
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you for the help.

Tried the solution from the link and it works perfect now.

Also installed newest 1.0.3 IDE and it also works out of the box. I was using 1.0.1 because that's what yum installs.

All set now! smiley
Logged

Pages: [1]   Go Up
Jump to: