Pages: [1]   Go Down
Author Topic: unable to open all my sketches contained in one folder.  (Read 460 times)
0 Members and 1 Guest are viewing this topic.
uk
Offline Offline
Sr. Member
****
Karma: 0
Posts: 314
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,

i have a number of sketches ive been using ok for ages ive now unable to open them for some reason, i have all my sketches in one folder which has worked fine for ages now for some reason im unable to open them, is there any way to open them?

thank you


* new.png (92.15 KB, 510x602 - viewed 21 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The message is saying that a sketch was found in a wrong place. It should have been located in a folder having that same name.

This happens sometimes, e.g. if you rename a file without renaming the folder (directory) where it is located, or if you move or copy a sketch from one folder to another.

The solution is to place that file (.ino) in the required folder. If the folder does not exist, you can create it manually and move the sketch inside.
Logged

UK
Offline Offline
God Member
*****
Karma: 17
Posts: 568
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you upgraded IDE version?

As the prompt says, IDE 1.xx requires sketches to be within their own folder. It's telling you it will fix the issue for you if you just click OK.

So.....click OK and IDE will create the folder, move the file, and open it.

When you're choosing sketches from the file menu then you won't see any difference. If you browse using your OS File Manager the you'll find your sketches are now organised nicely.
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17259
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Also in the IDE files menu there is a preference section that tells you where and what user's sketch folder name the IDE is looking to find any sketch folders that contain sketches of the same name as the folder name. So check your preference location to see if that is where you actually have your sketch folders located at and if not change the preference location.

My preference path when running arduino IDE 1.0.3 is shown as:

C:\Documents and Settings\Primary Windows User\My Documents\Arduino\Arduino1

I change this ( to C:\Documents and Settings\Primary Windows User\My Documents\Arduino ) when I want to run a older version of the IDE where I have sketches not yet check out for arduino 1.x compliance.

Lefty
« Last Edit: January 18, 2013, 08:33:36 pm by retrolefty » Logged

Pages: [1]   Go Up
Jump to: