Pages: [1]   Go Down
Author Topic: errore pin non collogato con kicad  (Read 790 times)
0 Members and 1 Guest are viewing this topic.
grugliasco
Offline Offline
Jr. Member
**
Karma: 0
Posts: 94
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao a tutti eccomi con un problema con Kicad sto disegnando uno arduino stadalone ma quando cerco di verificare lo schema elettrico mi da errore (type 3) o (type 4) che recitano testualmente filo collegato a un pin che non è collegato a qualcos'altro.Con una versione vecchia di kicad potevo evitare questo problema perchè quando disegnavo le piste potevo farle in manuale ma con questa versione non ci riesco più quindi volevo risolverlo in modo definitivo.Cercando cercando in rete sembra che il problema nasca da come è stato definito un pin nel simbolo elettrico.Tecno
Logged

0
Offline Offline
Faraday Member
**
Karma: 30
Posts: 2905
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Forse intendi l'impostazione del pin specificato nel componente della libreria?

Beh si, se collegni due pin input input potrebbe darti quell'errore, anche se non a me sembra un bug che una funzione, controlla i componenti che contengono quel pin che da errore e cambiane uno in passivo e riprova.

Oppure se ti va, archivia il progetto e postalo.
Ciao.
Logged

AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

grugliasco
Offline Offline
Jr. Member
**
Karma: 0
Posts: 94
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

in genere il problema si evidenzia con la linea positiva o quella del gnd ma non riesco a capire perche rifacendo lo schema di quella parte incriminata l'errore ricompare in un altro punto dello. Ti allego lo schema in formato kicad Tecno

* arduino_brom.sch (21.32 KB - downloaded 16 times.)
Logged

0
Offline Offline
Faraday Member
**
Karma: 30
Posts: 2905
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

A me il link non funzia.
Logged

AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

grugliasco
Offline Offline
Jr. Member
**
Karma: 0
Posts: 94
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hai ragione neanche a me provo ad allegarlo di nuovo

* bromi.zip (25.33 KB - downloaded 18 times.)
« Last Edit: January 18, 2013, 03:17:47 pm by tecno » Logged

0
Offline Offline
Faraday Member
**
Karma: 30
Posts: 2905
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

A me continua a non fungere, ma non puoi hostarlo da qualche parte.

Ma su che micro è basato? 328 644 ecc.

Ciao.
« Last Edit: January 19, 2013, 06:15:14 am by MauroTec » Logged

AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

grugliasco
Offline Offline
Jr. Member
**
Karma: 0
Posts: 94
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

anche me non funziona e parrebbe un problema di server.Questa mattina smanettando  un po sono giunto  che il problema sia legato a come è dichiarato un pin nel simbolo del componente. Appeno ho finito se interessa posterò l'intero progetto (un ennesimo bromografo).
Tecno
Logged

0
Offline Offline
Faraday Member
**
Karma: 30
Posts: 2905
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Si è quello il problema, ci sono passato anche io, e ogni tanto faccio ancora l'errore.

Se ti interessa c'è una board con il 644 qui http://www.electroit.tk/index.php?action=dlattach;topic=3.0;attach=12

Controlla solo il pin header posteriore a 90 ° che mi pare non sia compatibile con il convertitore usbserial di Arduino, quello basato su 16u2.

Ciao.
Logged

AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

Pages: [1]   Go Up
Jump to: