Pages: [1]   Go Down
Author Topic: Problème Qt creator  (Read 708 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 89
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut à tous,
depuis quelques temps, je cherche a dévellopper un programme simple pour communiquer de l'ordi à l'arduino sans utiliser forcement le port série d'origine.J''ai donc découvert Qt creator pour le C++ . Mon problème est que lorsque je lance la compilation du programme, j'ai ce message :
Code:
Qt creator needs a compiler set up to build. Configure a compiler in the kit options.

Et là, je sais plus quoi faire.
Aidez moi S'il Vous Plait !!!

Ps: je suis sous mac os X lion, j'ai Qt 5.0.0 (celui qui bug) les debug librairies et toutes les autres dispo sur Qt

Merci de votre Future je l'éspère Aide
Logged

Venez visiter mon site web !!
http://arduino.leforum.eu

France
Online Online
Faraday Member
**
Karma: 38
Posts: 3541
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si c'est un problème Qt, il y a certainement des forums plus à même de t'aider.
Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonjour,

1) installe Qt5 version final (les versions RC et beta sont déprécié désormais)
2) Dans Qt Creator : Outils -> options ... -> "Compiler & Executer"
3) Tu as plusieurs onglets :
- dans "kit" tu as la liste des kits (duo version de Qt + compilateur) Qt disponible, tu doit trouver Qt Desktop 5.xxxxx
- dans "Version de Qt" tu as la liste des versions de Qt disponible, tu doit trouver Qt 5.xxxx ... SDK
- dans "Compiler" tu as la liste des compilateurs disponible, sous mac tu doit surement avoir GCC

Si ce n'est pas le cas c'est que ton installation de Qt est foireuse, dans ce cas tu peut créer un nouveau kit manuellement en choisissant le compilateur et la version de Qt à utiliser.
Ensuite dans le dossier de ton projet Qt tu supprimes le fichier ****.pro.user et tu reouvre le projet.
Normalement Qt va te demander de choisir le kit  à utiliser et les cibles à générer, tu choisis le kit précédemment créée et tout sera ok.
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Offline Offline
Jr. Member
**
Karma: 0
Posts: 89
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Si ce n'est pas le cas c'est que ton installation de Qt est foireuse, dans ce cas tu peut créer un nouveau kit manuellement en choisissant le compilateur et la version de Qt à utiliser.
Ensuite dans le dossier de ton projet Qt tu supprimes le fichier ****.pro.user et tu reouvre le projet.
Normalement Qt va te demander de choisir le kit  à utiliser et les cibles à générer, tu choisis le kit précédemment créée et tout sera ok.
En choisissant le compilateur ?? mais où ???
Logged

Venez visiter mon site web !!
http://arduino.leforum.eu

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

En choisissant le compilateur ?? mais où ???
J'en sait rien j'ai jamais utilisé mac, il faut que tu installes GCC ou un équivalent pour mac.
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Pages: [1]   Go Up
Jump to: