Go Down

Topic: Keywords not Highlighting Brown or Orange (Read 1 time) previous topic - next topic

budder8818

I have written a library called motor. Which complies and is recognized in the Arduino libary.

It is at: arduino-1.0.3-windows\arduino-1.0.3\libraries\Motor

I have these three files in there:
keywords.txt
Motor.cpp
Motor.h

when i open a sketch and include motor the key words i have specied in the keyword.txt doc do not highlight. Any ideas why?

my txt

Motor KEYWORD1
setpPin KEYWORD2
setnPin KEYWORD2
idle KEYWORD2
foward KEYWORD2
backward KEYWORD2
update KEYWORD2
test KEYWORD2
getTime KEYWORD2

eried

Can you post your library to check it out?

Also, you can use Documents/Arduino/Libraries.
My website: http://ried.cl

robtillaart

IIRC there was something with the keywords.txt file, the separators should be all TAB chars and no other white-space char.
also you need to restart ALL IDE's after changing lib files.

(The tip from eried to use Documents/Arduino/Libraries is important! Think what will happen when you upgrade the Arduino to 1.xXX)
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview