Go Down

Topic: Arduino software does not launch in Windows XP (Read 1 time) previous topic - next topic

Hemiman

I have the Windows version downloaded and installed into the "Program Files" of my C driver as the instructions say.  However, when I launch the executable I get an error after a long wait I get a pop box that says "An error occured while starting the application"  What do I do?  BTW, my Arduino board is recognized by my OS when I plug it in and I've got a driver loaded for it.  Now if I can just get the app to run.  Thanx

lost_and_confused

Sorry, but I think you may need to specify which software/IDE/compiler you installed.

I tried the new one which doesn't need JAVA.

Alas I have problems with it because I am missing a required DLL file.

That took me a few hours to discover.

I am not saying this is your problem, but you haven't said which version you are trying to install.

Hemiman

I downloaded the latest under "Windows" on the download page.  I believe it is 1.0.3

lost_and_confused

What happens if you load the IDE/program with no sketch?

Just to make sure there aren't any other "monsters" causing you problems.

Let's just see if the IDE can load ok first.

:)


Hemiman

Ok, here is where my inexperience is going to show :)

I'm not sure what you mean by IDE.  I bought one of those DF Robot Rovers.  I've got the robot assembled ok and it is recognized by my computer when I plug in the USB cable.  The instruction manual says to download the Arduino software, which I did and ran the Arduino.exe.  That's where I get hung.  I'm assuming that by opening that up and can cut and paste a "sketch" of test code recorded in the manual.  However, the software won't start.

lost_and_confused

Sorry.

I am getting stuck with the language myself.

Try running the compiler but JUST the compiler.   Don't load a sketch.

I don't know if you double click on a sketch to load the compiler, or load the compiler then load the sketch.

So:  Find the compiler's icon and double click it and don't load any sketches.  See what happens.

Hemiman

If I understand what you are saying to; try and launch the Arduino.exe interface without any sketch.  The compiler is part of that program?  I get the Arduino splash screen but never make it into the interface itself.  It errors out and the program closes.

lost_and_confused


Hemiman

Thank you for your patience :)  I'm learning.  You mentioned there might have been a missing DLL file?  I could download an older version and try that?

lost_and_confused

I am not that far from the bottom of the learning curve myself, and so I think I am more understanding of how you feel.

I can't say what I mentioned is your problem, so really I don't think you should concentrate on this specific thing.

You didn't way what happens when you try to run "arduino.exe".

I'm guessing it doesn't work.  But what "Error" does it give you?

Also, I am not always online.  I am actually trying to get other things working.

If your earlier version worked and the new one doesn't:  I would seriously suggest you go back to the older version for now.

As it works, concentrate on learning the Arduino rather than chasing these problems with the programs, etc.

Although eventually you will/may have to deal with them, for now, enjoy the Arduino and don't let these problems annoy you.

alah

I recently downloaded and installed v 1.0.3. with XP. I can l aunch it without any problem; try reinstalling.

Go Up