Go Down

Topic: Usb seriale con atmega328p standalone (Read 2786 times) previous topic - next topic

superzaffo

Allora, come avrai letto prima.. il micro lavora benissimo sulla board arduino... cosa che invece non avviene nella breadborad. Naturalmente il micro è lo stesso... smontato e rimontato  :smiley-eek:
L' oscillatore l'ho appena anche provato a cambiare, ma niente lo stesso...e ti posso assicurare che è collegato come nello schema del fornitore... collegato tra i pin 8 e 9 in serie con i condensatori verso gnd.
Ho anche usato la guida di Michele....

Brunello

"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

tonid

Se è così il problema dovresti averlo per forza sulla breadboard ,controlla,senza tensione,che ci siano tutti i collegamenti,non fidarti dei fili che a me è capitato con dei cavetti nuovi di rin...ire e alla fine era un cavetto che era interrotto,quindi usa il tester.....
Se una volta caricato lo scketch e lo passi in stand alone devi vedere per forza il blink lampeggiare...

edit.  esatto il quarzo è tra il 9 e il 10

superzaffo

Lo so Brunello... Va a finire che mi faccio un piccolo circuito con i millefori.. perchè mi sembra proprio strana sta cosa...

Brunello

lo so' che lo sai, ma sei stato tu a scrivere

Quote
collegato tra i pin 8 e 9 in serie con i condensatori verso gnd.
"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

superzaffo

Volevo dire che ni stavo passando tutti i cavi con il tester e controllando tutti pin...
Niente... cosa veramente strana...
E se provassi alimentarlo da un 7805 ? secondo te potrebbe cambiare qualche cosa ?

Brunello

Quote
E se provassi alimentarlo da un 7805 ? secondo te potrebbe cambiare qualche cosa ?


che senso ha, dato che i 5V li fornisce il convertitore ( che li preleva dall'USB)
"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

superzaffo

guarda, sto cercando il cosidetto pelo nell' uovo...  :D
O è un problema di bradboard (cosa che stento a credere perchè già usata per altri progetti) o sono io che non riesco più a leggere uno schema...   :smiley-fat:
adesso riprovo a ricomporre il tutto di nuovo.. magari con i fili rigidi e vediamo...

superzaffo

Ok ora ho provato a rifare il circuito e a cambiare breadboard ma niente non vuole funzionare.
Vi posto una foto così vedete il circuito...
C'è qualcuno che mi sa dare una mano ? perchè ora non ci capisco niente.
(ricordo che il chip è già programmato con il blink e un serial.print)
Grazie

leo72

Togli il condensatore in serie sulla lina che va al pin di reset e riprova a programmarlo. A tanti dà noia.

Brunello

perche' non lo metti piu' lontano quel quarzo.......
"C' è chi legge Guerra & Pace e non ci capisce un tubo vuoto; c'è chi legge l'etichetta delle patatine fritte e ci trova la spiegazione del mondo" (J.S. S. architetto napoletano)

superzaffo

Ok ragazzi ho risolto... Inanzi tutto grazie a tutti per gli aiuti.
Ho cambiato il quarzo con un altro (il secondo) e ha iniziato a funzionare... :smiley-eek:
Quindi probabilmente hanno spedito al mio amico un quarzo difettoso... Ora funziona anche la programmazione via seriale...
Grazie a tutti ancora.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy