Go Down

Topic: Trying to use Arduino Uno R3 as ISP for ATTiny2313 (Read 3907 times) previous topic - next topic

gringle

Hm, thanks, but re-re-re-checked and checked again when you said it is wrong, I have no idea what might be wrong. It is wired excactly like it is described in the tutorial and I double checked with the picture also, just to be sure. The ATtiny2313 is not upside down. I don't know what to do different.
I guess the resistors would only prevent damage but not solve my problem, right?

Coding Badly

I guess the resistors would only prevent damage but not solve my problem, right?


Right.

Quote
I don't know what to do different.


Post a picture.  Ensure everything is well lit.  Move the camera away and zoom to frame.  Try to make it about 800 x 600.

gringle

Here it is, thanks for having a look. I kind of hope to be embarrassed by you spotting the error right away.

Coding Badly


Perfect picture.  Very nicely done.

Huh.  Wiring looks fine to me.

Post the verbose output from avrdude with the target removed.  (I think it will fail with a timeout.)

gringle

I will do that this evening. I'm not sure what you mean by "target removed", though. Just without the ATtiny2313?

Erni

Another thing to try is moving the chip to another spot on the breadboard or another breadboard.
If have experienced bad contacts on one mine, althoug not shortycuts.

gringle

I was finally able to upload the Blink sketch to the ATtiny2313! I tried Ernis suggestion and moved it to a different breadboard and it worked right away. I feel kind of stupid for not thinking of trying that on my own.
Thanks so much for your help, guys.

Go Up