Go Down

Topic: Opamp - is this a floating problem (Read 1 time) previous topic - next topic

2Tricky

Jan 20, 2013, 04:57 pm Last Edit: Jan 21, 2013, 11:31 am by 2Tricky Reason: 1
I have an odd problem involving a LME49710 opamp.  I am developing my circuit to light up a particular LED based on a comparitor funcion (the opamp).  My circuits' supply is the 5V regulated Arduino output and the grey-scale sensor typically outputs between 0.2V and 2.0V.

I choose (set) the reference on the '-' pin using a 500k linear pot. The sensor is wired straight to the '+' pin without any pull down resistor etc.  All seems basically ok but regardless of the chosen voltage reference point (this depends upon the greyscale value under the sensor) the pot is always at very nearly full tilt - where the voltage returned is about zero - ie nearly grounded.

Do I need a pull down resistor to stop the sensor floating or...

Thanks a lot

dhenry

Quote
Do I need a pull down resistor to stop the sensor floating or...


What does the datasheet say?

2Tricky

#2
Jan 20, 2013, 07:36 pm Last Edit: Jan 20, 2013, 07:45 pm by 2Tricky Reason: 1
There are no diagrams as such for comparator circuits but for those circuits shown, some have resistors to ground and some don't.  I would take this to mean it depends upon other criteria.

For the sensor, no such information is given.  My suspicion was aroused by a question I posed to the manufacturer, at which point they said the analogue output was completely independant of the voltage in.  I took this to mean that the resulting signal was created from a light sensitive component of sorts and without boosting - but 2.0V sounds a lot and so I now question this.

The datasheet page is: http://www.farnell.com/datasheets/37189.pdf

Thanks

MarkT

The opamp has a bias current of 7nA - should it be fed a voltage from a high-impedance source that bias current will produce
a voltage error.   For a 1M impedance it would be a 7mV error, for 1k impedance only 7uV (well below the input offset spec
of 50uA).

So if your grey scale sensor has a low impedance (1k or below rather than 1M) there will be no problem.

However that opamp won't do what you want from 5V supply (the strict minimum supply voltage is 5V, and has a common-mode
input range of only 2 to 3V at that supply).

You need a comparator ideally, or if an opamp a rail-to-rail input opamp - this particular opamp is designed for high-end audio,
not low voltage.
[ I won't respond to messages, use the forum please ]

2Tricky

MarkT thanks.

So the line that reads: Power Supply Voltage Range ±2.5V to ±17V indicates that it must go from negative to positive - presumably in approx equal measure.

Although I have poured over many examples in my quest to understand opamps, I don't yet know how to make the evaluation you make here:
Quote
For a 1M impedance it would be a 7mV error, for 1k impedance only 7uV (well below the input offset spec of 50uA)

and I'll make it my next aim.

Would a negative regulator be useful such as the ICL7660SCPAZ found here: www.intersil.com/content/dam/Intersil/documents/fn31/fn3179.pdf

Thanks for your help.


Go Up