Pages: [1]   Go Down
Author Topic: My Grove Relay doesnt work!!! Why?  (Read 555 times)
0 Members and 1 Guest are viewing this topic.
universe
Offline Offline
Sr. Member
****
Karma: 0
Posts: 258
I'm enjoying my Life
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I just bought a relay, here is the relay: http://www.seeedstudio.com/wiki/GROVE_-_Starter_Kit_V1.0b
I connect the pin D1 to the pin 7 Arduino, then pin Com to 5V, then pin ON to the LED, then pin VCC to 5V, then pin GND to GND Arduino.

Then I upload this coed to Arduino:

void setup()
{
pinMode(7,OUTPUT);
}
void loop()
{
digitalWrite(7,HIGH);
}

but nothing happen to my led and nothing click from the relay...
Does it mean my relay broken?
How to check it?
Logged

UK
Offline Offline
Shannon Member
****
Karma: 222
Posts: 12534
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That sounds as if it should be enough to operate the relay, but I don't know what LED you're referring to. Does the LED on the relay board light up?
Logged

I only provide help via the forum - please do not contact me for private consultancy.

universe
Offline Offline
Sr. Member
****
Karma: 0
Posts: 258
I'm enjoying my Life
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

the led on the board also did not light up..

this kind of led I refer to, but it is with different relay
Logged

UK
Offline Offline
Shannon Member
****
Karma: 222
Posts: 12534
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

this kind of led I refer to, but it is with different relay

I don't understand what that means. Is there a second LED involved, somehow?
Logged

I only provide help via the forum - please do not contact me for private consultancy.

universe
Offline Offline
Sr. Member
****
Karma: 0
Posts: 258
I'm enjoying my Life
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

this kind of led I refer to, but it is with different relay

I don't understand what that means. Is there a second LED involved, somehow?

What I mean is: that kind of schematic I do for my grove test, but not with that kind of relay.
I use the relay from here: http://www.seeedstudio.com/wiki/GROVE_-_Starter_Kit_V1.0b
Logged

UK
Offline Offline
Shannon Member
****
Karma: 222
Posts: 12534
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What I mean is: that kind of schematic I do for my grove test, but not with that kind of relay.
I use the relay from here: http://www.seeedstudio.com/wiki/GROVE_-_Starter_Kit_V1.0b

I'm still confused. You're the only person who has suggested which relay you're using, and you have only identified it by reference to the GROVE starter kit. Are you saying now that your relay is not the one from the GROVE starter kit?
Logged

I only provide help via the forum - please do not contact me for private consultancy.

Queens, New York
Offline Offline
Faraday Member
**
Karma: 84
Posts: 3400
"Of all the things I've ever lost, I miss my mind the most" -Ozzy Osbourne
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So the LED you wired up is OFF? You do know that D1(pin 7) turns the relay on and off, right. Also that relay is normally closed when its not being powered, which means the LED should be lit. If D1 is always HIGH then the relay is open, and the LED is OFF.

Now if the Onboard LED is also off then it could be that the 5 volts is not enought to power it.

Just pointing that out.
« Last Edit: January 22, 2013, 12:23:47 pm by HazardsMind » Logged

Created Libraries:
NPV2 (NewPasswordV2),  TFT_Extension, OneWireKeypad, SerialServo.
Will provide libraries if asked in PM or forum.

Pages: [1]   Go Up
Jump to: