Go Down

Topic: Windows 7 -> driver installation -> code 10 (Read 4578 times) previous topic - next topic


hi,    (im using a Dell laptop, with Windows 7, x64)

Yesterday i used my new Arduino UNO for the first time. I've downloaded the Arduino Software on the official website, and unzipped the folder. I plugged in the USB cable with my Arduino UNO board. I opened the Arduino.exe and i opened the Blink example. I uploaded it and it seems it was successfull. The LED was blinking on/off. But after that, i've changed the code in the Blink example (i would let blink 2 leds) and tried to upload it. Then i get the error: Serial port 'COM3' can't be found. I looked in the menu at extra--> serial port. This is unclickable and grey.

I searched on the Arduino site (and forum and Google) for errors and troubleshooting but i can't get it working. But i know, i forgot to installate the driver for the Arduino UNO. So i went to the Configuration Window of my laptop, choose Hardware & Sounds --> Device Manager. In the list with devices i tried to find the Ports (COM & LPT), but it was in my list. I neither found 'Unknown devices' in the list. I enabled in the Menu --> View --> View hidden devices. It doesnt work. After that I tried in the menu 'Add older hardware'. There i chose 'Looking for hardware and installate automatically. In the following list i clicked on Ports (COM & LPT). In that list i see Arduino LLC (www.arduino.cc). I clicked on Browse and chose the arduino-1.0.3/drivers/Arduino UNO.inf . In the following list i clicked on Arduino UNO and then on Next.

The installation began and then came the following message: The next hardware is installed: Arduino UNO. The software for this device is installated, but it seems it does not correctly work. This device does not start (Code10).

I have tried everything. I tried it on another computer + Laptop (both with Windows 7), and nothing happened. It seems the Arduino (or usb cable) is not recognized. The LED on my Arduino is still working and the ON light is green. An orange light (L) is ON/OFF/ON/OFF.. I've pressed the RESET button on the Arduino but nothing helps me...

Please, can somebody help me? Thanks in advance. (Sorry for my bad English) 


There is a refresh button in the device manager to scan for new devices.
Also the arduino needs to be plugged into a root usb port, try it on all the others, ( back ones are most probably root ). Some pc's & laptops provide extra ports by having an internal hub, these are not suitable for uploading the code.

I would also check the driver, maybe there are different drivers for the original UNO and the new R3.

Verify your cable with another working device.

Before you begin, if you installed a driver ( that didn't work ) open device manager and uninstall it completely.

If you have another PC try to install it on there to verify the arduino ( although it is most probably not the reason ).


Thanks for your advice. But nothing works.

I uninstalled all the Arduino folders/software but nothing happened. Is there a manuel way to find new USB plugins in your computer? Everytime i plug a USB plugin in my laptop, a sound will folow. Only with my Arduino UNO (ofcourse with USB cable) not... 

I also tried it on a Netbook with windows XP. Nothing happened.

Is there something wrong with my Arduino? (i dont think so because the lights are ON and the LED still blinks as the Blink example, that i've uploaded, wants)


Definitely sounds like a problem of some sort, windows should respond when a plug and play device is attached ( usb is one ), it should even do this for device it doesn't recognise and ones that it thinks are malfunctioning. Open up services.msc ( type into start->run ), make sure the 'shell hardware detection' service is started.

But then, both your computers would have to have this disabled, not really likely as the service is set to run by default.

I think the board may be fine, just not usable, yet.
On the uno is a little black square, it is a second micro controller chip that is there to run the usb to serial transmission. It may not have been programmed at all / correctly.

What you can do is jump on ebay and grab an avr isp programmer, then you can use the uno while also attempt a re-flash of the usb controller.

Or you can borrow a mates Arduino and use it as an ISP ( plenty of articles on howto ).


Thanks for your help!

I think i have to borrow another Arduino than... Damn man, never had problems before with this Arduino (on another laptop with Windows XP)...


This is exactly the same problem that I am having. What exactly is the right driver to use for the Hobbyking Multiwii Pro Flight and where to get it. Mine says arduino but has exclamation there and gives me:

This device cannot start. (Code 10)

Did you ever get a resolution for your problem?



Sep 09, 2014, 04:59 pm Last Edit: Sep 12, 2014, 09:11 am by BF72 Reason: 1
Hi, I am witnessing very strange behavior around the same problem:

I have two Arduino Uno's. When I plug one into my computer, everything works fine, and Device Manager says it is Com4. When I plug the other one into the same USB port, Device Manager gives the topic error ("This device cannot start. (Code 10)") and says it is on Com5.

I tried replacing the Atmel ATMEGA328 chip on the "faulty" board with a new one off Ebay, but with the same error.

The other odd thing is that when I plug in the "good" board, the L LED (pin 13) is off. When I plug in the faulty board, the L LED is always on (when I hit the reset button, it flashes quickly a few times and then stays on). When I ground pin 13 it goes off, but comes back on immediately after I unground it.

So it seems there is something faulty on the board, but it's not the Atmel chip. By the way, the board was working fine for several months before this came up. I'm flumoxed, any ideas?


In case it helps others, I found a partial solution to the above problem. I still can't get my computer to talk to the "faulty" Arduino Uno via USB cable, but I can program it using my "good" Arduino Uno. First, wire them together as shown here: https://dlnmh9ip6v2uc.cloudfront.net/assets/3/b/d/8/1/523b53bb757b7f01268b456a.jpg / https://learn.sparkfun.com/tutorials/installing-an-arduino-bootloader.  Then open the sketch you want to upload, go Tools / Programmer / Arduino as ISP, and then Upload. It uploaded the sketch to both boards, and the "faulty" board successfully ran the program (but still wouldn't communicate via USB).

It's going to be a pain to wire two Arduinos together each time I want to program the faulty one, but if it doesn't need to be programmed often, than this is better than bricking it.

By the way, before stumbling on the above solution, I tied reinstalling the bootloader on the "faulty" board, but that didn't fix not-communicating-via-USB problem.


I had a similar problem with Arduino nano atm328, error 10, but i had another good one, so i decided to check it out what if i compare pins and components from good one to error one and surprise, my error 10 board had a problem with regulator AMS1117, if i test diode from pin 5V to output from regulator AMS1117 i get 1.5KOhms but in the good one board i get 0.00, it means that pin 5V to output from AMS1117 should be in short circuit.
i'll try to remove it to figure out if it's the problem.

Best wishes.

Israel M.


I think I have found solution to the problem described above in case of arduino uno with CH340 USB-to-serial chip in Winodws 7 32 bit. Just update the COM driver with drivers for  CH340 USB-to-serial chip which can be downloaded from http://javacolors.blogspot.com/2014/08/dccduino-usb-drivers-ch340-ch341-chipset.html. Although the site describes a solution for Macbook, it contains also drivers for windows. This solution worked for me. (Exchange of usb CABLE and Arduino driver reinstalation did not work for me).
with regards


Mar 31, 2015, 12:32 am Last Edit: Mar 31, 2015, 01:30 am by jasfeliz
Hello everybody,

I had the same problem after install the Arduino 1.6.1 in my HP EliteBook 8460p with Windows 7 Enterprise x64.

I get the same ERROR, in spanish: "Este dispositivo no puede iniciar. (Codigo 10)".

This error is related with the installation of the Arduino driver for Windows 7 x64.

The same board with the same cable in two other PCs works properly.

I also install the same Arduino 1.6.1 software in my kid's PC with Windows 8 x64 and using the same board (Mega 2560) with the same cable, and everything works perfectly because Win 8 already detect the I/F chip in the Arduino clone board.

You can try to reinstall the driver in the Control Panel-System-hardware, and it will result imposible if you have the wrong drivers, the problem will still there.

A combination of USB drivers and the driver provided with the Arduino 1.6.1 for Windows 7 x64 have some type of incompatibility. Now the turn is for the software development people to solve it including other chips in the installation drivers recognition.

As bmasojc commented, try to install the drivers for a different USB controller like the CH340G chip. This chip is very common in Cinese clone boards and I attach the drivers provided by the chip manufacturer.


@jasfeliz: Hi, thanks for this very helpful post (especially the drivers) - very appreciated!


Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131