Go Down

Topic: Arduino 3G Shield: cannot run camera ! (Read 668 times) previous topic - next topic

Neomane

Hello,

I have received my 3G shield few days ago then I tried to send SMS, it works fine but when I tried to test take picture sample I have no response at the step

AT+CCAMS

The program still wait for "OK" response but nothing happens,

but by adding some verbose logs by testing response on serial line I have sometime these type of strings:

VIEAL NTSAE ÿÿÿÿÿÿÿÿÿÿÿÿÿTCASÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ
AEAN ESR


and other time a more explicit message as

CAMERA NO SENSOR

despite the camera is well connected,

Notice that at beginning I have supplied my card with USB and after by an external supply of 18V, I hope that the card and the shield support this voltage ....

If someone could give me a beginning of explanation  :~

Nick Gammon

Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

PeterH


Notice that at beginning I have supplied my card with USB and after by an external supply of 18V, I hope that the card and the shield support this voltage ....


Unless you know that whatever it is will accept an 18V supply, this is rather risky and could easily have burned something out. If it was previously working and now no longer works then I'm afraid there's a good chance you've blown it.
I only provide help via the forum - please do not contact me for private consultancy.

Neomane

The code I used is from sample you can find at this URL http://www.cooking-hacks.com/index.php/documentation/tutorials/arduino-3g-gprs-gsm-gps#step8
Blocking occurs at this step:

Serial.println("AT+CCAMS");     //starts the camera
while(Serial.read()!='K'); // <-- OK not received !!!!


Concerning supply of 18V, Arduino specs describe that the upper voltage limit is 21V,the card seems to work well and the 3G Shield too since I can send and receive SMS and LED continue to blink at startup, the only suspect behaviour I can see is when I want to use the shield as 3G modem, Windows (7) don't find the driver but still as an "Unknow device"

Could someone have any idea please ?


Nick Gammon

What was the objection to pasting it here?

If this is it, and that isn't certain, what does this do:

Code: [Select]

void loop(){

    delay(1500);
   
    while(Serial.available()!=0){
        Serial.read();
    }
   


It looks to me like it discards incoming serial data.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

Go Up