Go Down

Topic: Arduino Compiler doesn't compile a particular sketch. (Read 12034 times) previous topic - next topic


What, exactly IS \". The \ is an escape character. It assigns special meaning to the character that follows. So, what special meaning is assigned to \"? The meaning is NOT the same as ". It is that special meaning that you are inserting into the variable c, not a ".

The second assignment does insert a " into c.

I still don't see a bug in the IDE. It is properly defining different meanings to " and \".



it IS a valid escape sequence. It doesn't have sense in that contex, you are right, but compiler doesn't care; It is a escape sequence, it mean ". return.  :smiley-mr-green:

btw as you can see from the second bug (and i think you haven't read it to say so) this overflow is breaking some "good" code, so it is a ide's bug.

btw if the IDE's start to complain about the code you write, and not the compiler, I think there is something weird going on

edit: here the "other bug", just to be sure we are talking about the same thing http://code.google.com/p/arduino/issues/detail?id=962
Guida per principianti http://playground.arduino.cc/Italiano/newbie
Unoffical Telegram group https://telegram.me/joinchat/ALRu8ACkdTdXyz-2P7v13A


Hi all,
I have the same problem with my sketch.
A long list of at java.util.regex.Pattern$Branch.match(Pattern.java:4604)

In my case, the problem is generated by this function of the EEPROMAnything.h library:
EEPROM_writeAnything(0, miaStruttura);

I also tried to use the library functions "avr/eeprom.h":
eeprom_write_block((const void*)&miaStruttura, (void*)0, sizeof(miaStruttura));

The struct miaStruttura is a global variable defined as follow:

struct Struttura{
  int val1[4];
  int val2[4];
  int val3[4];
  int val4[4];
  char ID[8];
  int ADDR;
  char name[20];
} miaStruttura;

Someone can help me?
Thank you in advance!


Someone can help me?
Someone can post ALL of their code?


thank you for the advice.
An example is my fault.

Serial.print(F("SRAM controling ... ""));

Double '' at the end of the command.
This caused the error described in the introduction to the topic.


A typo like   
   info("<<<" "+rxData);   (3 quotes)
also causes this problem...


info("<<<" "+rxData);   (3 quotes)
also causes this problem...
Which version of the Arduino IDE are you using?

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131