Go Down

Topic: Arduino Mega und Ethernet (Read 849 times) previous topic - next topic

mcGeorge

Hallo,

es handelt sich um das "Arduino Ethernet Shield R3" (nehme extra schon original, um ärger zu verhindern)

der 6polig ICSP-Anschluss ist ok und sieht zumindest ordentlich verbunden aus.

Ja, ich nehme eine externes Netzteil mit 9V.

jurs


der 6polig ICSP-Anschluss ist ok und sieht zumindest ordentlich verbunden aus.


OK, der ICSP Anschluss ist mit Deinem Board verbunden, und damit sollte auch Dein Ethernet-Shield mit Deinem Mega-Board funktionieren, denn angesprochen wird das Shield über diesen ICSP Anschluss und damit die SPI-Datenleitungen.

Statt wie beim UNO D11, D12, D13 also beim MEGA D50, D51, D52.

Ab Ethernet Shield Rev3 und höher sollte die Kompatibilität zum Arduino MEGA vorhanden sein.

Ich persönlich habe keinen MEGA, eventuell könnte eine kleine Inkompatibilität beim "Slave Select" (SS) Pin bestehen, also Pin10 am UNO und Pin53 am MEGA, das konnte ich der Doku nicht genau entnehmen.

Aber wenn Du ein aktuelles Ethernet Shield (Rev 3 oder höher) und die aktuelle Ethernet-Library verwendest, und dann ein einfaches Beispielprogramm, bei dem Pin10 nicht im Sketch verwendet wird, sollte das eigentlich auf einem MEGA genauso laufen wie auf einem UNO.

Ich würde es eben erstmal nur mit einem sehr einfachen Sketch ausprobieren, der nur das Ethernet-Shield und die Netzwerkschnittstelle anspricht und nicht gleich mit einem Riesenprogramm, das gleichzeitig womöglich auch noch die SD-Karte verwenden soll.

Go Up