Go Down

Topic: <SOLVED> ATmega644 does not catch the interupt (Read 2 times) previous topic - next topic

corprius

PB2, ATmega644 pin 3

Nick Gammon

WInterrupts.c is confusing with all the defines, but this looks relevant:

Code: [Select]
    case 4:
      EICRA = (EICRA & ~((1 << ISC20) | (1 << ISC21))) | (mode << ISC20);
      EIMSK |= (1 << INT2);
      break;


Given that you want an INT2 interrupt, it looks like attachInterrupt (4, foo) is what you want. Try it anyway, and see what happens.
http://www.gammon.com.au/electronics

Nick Gammon

Also see this thread:

http://arduino.cc/forum/index.php?topic=147080
http://www.gammon.com.au/electronics

corprius

Your the best! That solved the problem!

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview