Go Down

Topic: [SOLVED] Resolding 16u2 --> stk500_getsync(): not in sync: resp=0x00 (Read 694 times) previous topic - next topic

Borrajo

good afternoon to all, for more than two years that I have my Arduino but I've never needed to ask anything in the forum, until today! I have three Arduinos to which they are burned (dead) the ATMEGA16U2, then took them off, buy a new and resoldered.
I put in DFU mode, and install your firmware with FLIP. The three Arduinos are recognized by the computer and create their serial ports (COM). Everything seemed to work well but when I tried to load the BLINK to arduino IDE told me: avrdude: stk500_getsync (): not in sync: resp = 0x00. The three Arduinos report the same error. Successfully loaded the bootloaders of the three Arduinos by LeonardoISP. The LED L flashing it 3 times when I plug the USB (indicating that the bootloader is loaded). The most important thing is that when you are uploading the sketch, the Rx light flashing it 3 times, but the light never turns Tx. I do not know what else to think, I hope some of this great community knows what to do, thank you very much! =( =( =(

Manuel Borrajo from Argentina.

pito


Borrajo

yes, I think so.
* in Device Manager, Ports (COM & LPTs) speed: 9600.
* in preferencias.txt arduino, speed: 9600.
I do not know where to look 328p speed.

pito

#3
May 28, 2013, 09:25 pm Last Edit: May 28, 2013, 09:35 pm by pito Reason: 1
9600 - There is no such speed with arduino's bootloaders, afaik- they are 19k2, 57k or 115k..
The upload speed match between 16u2 and 328p is important - used by avrdude..
What 16u2 firmware and 328p's bootloader did you flash into?

Borrajo

I put the firmware 16u2 "Arduino-usbserial-ATMEGA16U2-A-Rev3.hex" I loaded with FLIP atmel. 328P bootloader and loaded it with ARDUINO (LeonardoISP and burn bootloader), so I do not know what exactly loaded file. also loaded the files with a ISP programmer via Serial (COM1) and the result is the same.

hiduino

Did you set the fuse bytes for the 16U2?  FLIP will not set those.
With the default fuses it will be running at 1MHz.

I believe they should be lfuse=0xef, hfuse=0xd9, efuse=0xf4, to use the external 16MHz crystal.




Borrajo

SOLVED!!!

C:/avrdude -F -p at90usb162 -P COM1 -c siprog -U flash:w:ARev3.hex -U lfuse:w:0xFF:m -U hfuse:w:0xD9:m -U efuse:w:0xF4:m -U lock:w:0x0F:m

GRACIAS!!!

Borrajo.

Go Up