Pages: [1]   Go Down
Author Topic: Ardweeny Programming Failure - Strange Problem  (Read 1239 times)
0 Members and 1 Guest are viewing this topic.
British Columbia, Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I'm relatively new to electronics, but not to computers or troubleshooting.

I have an Ardweeny, as well as an Ardweeny Multipack.  I run Vista-32 and have a CP2102 USB-FTDI connector.  It's a B75937, and the manufacturer's website (sadly in Chinese) is here:  http://item.taobao.com/item.htm?spm=a1z10.1.28-2539457881.1.DPBQHO&id=9667883527  I installed the drivers, and assume they work fine, as it shows up as COM4, and I shorted the TXD and RXD pins, and a loop-back test worked normally.

When trying to upload a test sketch (blink), it does not work.  Error code avrdude: stk500_getsync(): not in sync: resp=0x00

I had Arduino Uno selected.  Manufactuer (www.solarbotics.com) suggested I select Arduino Duemilanove with ATMega328 for compatibility but it still did not work.  Manufacturer suggested I connect RST on B75937 to DTR on Ardweeny.  No go.  I noticed there was a through-hole connector on the B75937 that says DTR.  I soldered a connector to the DTR on the B75937, and connected that DTR to the Ardweeny DTR, and I got some progress.  Now, when I go to the "tools" menu, or try to upload a sketch, the LED on the Ardweeny flickers, so I assume things are working correctly now.  Yet still, I get the same error code no matter what I do, even though loop-back tests on D0 & D1 work.  (I used the procedure I found here: http://arduino.cc/forum/index.php/topic,73748.0.html)

I am not sure what I'm missing, as there is nothing else I can find on google or these forums that seems to help my problem.  Please help.
Logged

British Columbia, Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

WELL WELL, after much hair pulling and troubleshooting and experimenting, I got it to work!!!!!!

I'll let everyone what's going on, because other people using the B75937 USB to FTDI will need to know this.  (this is valuable information)

First of all, this little adapter does not come with a DTR pin that the Ardweeny needs, but it does have a small through-hole soldering point for a pin.  I pulled out my soldering iron and using a spare row of header pins I had left over from another project, I made myself a DTR pin on my B75937.  It took me 5 minutes.

Secondly, there is a mis-print on the board of the B75937, which would explain why it was so cheap.  ($2.50 including shipping).  The TXD and RXD labels are mistakenly switched.  The proper connectivity is TXD -> RXI and RXD -> TXD.  Once I had switched the connection, and had the DTR connected, my Ardweeny (which I am very happy with) came to life!

I hope anyone googling problems with their B75937 USB to FTDI serial adapter with CP2102 chip can find this information handy and save themselves some frustrations.
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 452
Posts: 18694
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the follow-up. You have probably saved someone else a lot of time. smiley
Logged

Tampa, FL
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Gordon,
I have the same B75937  USB 2.0 to TTL UART 6PIN CP2102 Module Serial Converter. Verified by looking at the photo you helpfully included.

I want to connect it to my Ardweeny, but i am confused about which pin from the B7 goes to which pin on the Ardweeny's 6 pin header. Can you help with a pin to pin lineup? Please include the extra DTR pin. In the meantime, I will go solder a header onto the DTR through-hole.

thanks for your help.

~m0j0
Logged

Arduino Uno (IDE 22)
Ubuntu 10.10 Maverick

British Columbia, Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A picture is worth a thousand words, so here are 4.  You can see how I modified the USB to TTL adapter.

http://i.imgur.com/SWVIxfh.jpg
http://i.imgur.com/vkJi2oV.jpg
http://i.imgur.com/7295ADv.jpg
http://i.imgur.com/EEEK4wJ.jpg

I hope this helps.
Logged

Global Moderator
Boston area, metrowest
Offline Offline
Brattain Member
*****
Karma: 439
Posts: 23748
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

A more common mod, discussed here, is to cut the trace going to the RST pin, and connect that pin to the DTR hole with a wire.
Then a female-female adapter cable can be made with DTR to DTR, +5 to +5, Gnd to Gnd, and Rx to Tx, Tx to Rx (or vice versa as needed).

Electrically, the same result as what is pictured above.
« Last Edit: January 18, 2013, 09:38:26 pm by CrossRoads » Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

British Columbia, Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Crossroads, good point.  I bought two of these, as they are only $1.50 each (incl. shipping!) on ebay.  The one above I modified for general purpose use by adding all the header pins.  The other one I am considering mutilating in just such a fashion, but I'm holding off because it will just be a temporary solution, as I'm working on a Bluetooth adapter for my Ardweeny to do away with pesky cables altogether.
Logged

Tampa, FL
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks so much for the help and the great photos.
That's going to help me a lot. smiley
Logged

Arduino Uno (IDE 22)
Ubuntu 10.10 Maverick

Tampa, FL
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've given it a test.
I added a header pin to the DTR hole ( i have not yet cut the trace going to the RST pin, and connect that pin to the DTR hole with a wire as suggested)
Using the pictures as a guide, I connected the programming header on the Ardweeny to the B75937  with jumper wires. When I try to upload a sketch from the Arduino 1.01 IDE, I get an error:
Code:
avrdude: stk500_getsync(): not in sync: resp=0x00

I swapped the Tx/Rx connections and tried again. But I get the same error.

I am connecting like this:
on the Ardweeny, there is a six pin programming header, let's call it pin 1-6 where pin 1 is GND.
Code:
Ardweeny - B75937 
1(GND) - GND
2 - Nothing
3 - 5v
4 - Txd
5 - Rxd
6 - DTR

I have installed the windows64 driver from here:http://www.pololu.com/docs/0j7/all#2

In Arduino IDE, I a have selected Arduino Duemillnove w/ATmega328 on COM 5

Any ideas?
Logged

Arduino Uno (IDE 22)
Ubuntu 10.10 Maverick

British Columbia, Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I always did the loopback test to see how far the signal was getting, so that I knew where the problem was.  It's easy to do.  Short the RX and TX pins on your USB adapter.  Open a com program and connect, and type something random.  If the serial device sends back exactly what you type, then it works.  If it doesn't, your problem is with your serial adapter or driver.  Get that to work first.

Next, you can short some RX/TX pins on your Arduino, to know if the signals are getting to the processor.  I know how to do that on my Ardweeny, but you may have to do a web search how to do it on your Due.

On my Ardweeny, doing a loopback test would mean shorting the RX and TX pins (D0 and D1)

Also, a multi meter is very handy.  Put one pin on ground, the other on the DTR pin.  Get a com program that lets you toggle the DTR.  I recommend Realterm.  With loopback and multimeter, you should be able to trace the path of the signal and see where it stops.  Best of luck!
« Last Edit: January 29, 2013, 05:51:09 am by GordonShumway » Logged

Pages: [1]   Go Up
Jump to: