Go Down

Topic: Wenn Arduino mit dem Rechner nicht mehr redet.... (Read 2 times) previous topic - next topic

wilhem

Hallo zusammen!!!

Es ist so…
2010 kaufte ich meine erste Arduino 2009, mit deren Hilfe  ich über 2 Jahre lange ganz zufrieden Programme und eingebettete Systeme entwicklt habe.
Eines Tages, letzten Sommer, wollte ich nochmal meine Platine programmieren und plötzlich erkannte mein System keine USB Anschluss mit  Platine… Komisch dachte ich, da sie immer funktioniert hat und ich keine Treiber (neue oder alte) uminstalliert habe.
Dennoch stellte ich bald fest, dass die USB Verbindung nicht mehr erkannt wird. Ganz gleich ob Linux oder Windows, einfach stecke ich das Kabel USB rein und das System reagiert einfach nicht. Unter Linux liefert zum beispiel ein lsusb nur den Anschluss der Maus.
Jedenfalls dachte ich mir…es ist der kleine FT232 auf bestimmt „durchgebrannt". So kaufte ich mir noch eine 2009 letzte Woche um meine  Programme nach langer zeit weiter zu schreiben.
Die Platine konnte ich nur 2 male programmieren, bevor plötzlich nochmal Fehlermeldungen bezüglich der USB Verbindung nochmal auftaten. Wieder das gleiche Problem, die Platine wird vom System nicht mehr erkannt!!!
Also…2 Platine, gleiches Modell, und gleiches Problem.. Wie kann sein dass ich so viel Pech habe? Woran kann es umsonst liegen? Wie kann ich überprüfen, dass alle Komponente auf der Platine (insbesondere die USB Schnittstelle richtig funktioniert!?!?)

Ich verwende als Umgebung Debian 6, mein Laptop ist immer der selbe geblieben und die rxtx.org sind die letzte installiert. Ich habe weder ein neues Betriebssystem installiert noch mein altes formattiert…
Ich hatte beispielsweise NIE Probleme mit Arduino NANO 3.0 gehabt. Die verwendeten IDEs sind 1.0.1 und 1.0.3, dennoch erkennen beide nicht die Verbindung.
Kann es sein, dass der Strom aus der USB meine beiden 2009 zerstört hat!?!?

Danke euch allen.

Schönen Tag noch
Gruß

mkl0815

Hast Du die betroffenen Arduinos mal an einem anderen Rechner getestet? Evtl. ist ja der USB-Anschluss das Problem. Funktionieren denn andere Geräte am gleichen USB-Anschluss?

wilhem


Hast Du die betroffenen Arduinos mal an einem anderen Rechner getestet? Evtl. ist ja der USB-Anschluss das Problem. Funktionieren denn andere Geräte am gleichen USB-Anschluss?


Ja...und habe Knoppix auf CD Live und nun Kubuntu auf USB Stick installiert und trotzdem das gleiche Problem...
Die USB Ausgänge funktionieren mit anderen Geräte perfekt, zudem kann ich sowieso immer noch meine Arduino NANO programmieren.
Damit hatte ich nie (bisher) ein problem gehabt...

uwefed

Ist vieleicht der USB-Kabel kaputt?
Grüße Uwe

vieledinge


Ist vieleicht der USB-Kabel kaputt?
Grüße Uwe


Wäre auch meine Frage gewesen. Ich hab neulich ein neues USB-Kabel (50cm) gehabt, was am Drucker ohne Mucken lief. Der angeschlossene Arduino war damit nicht zum Arbeiten zu bewegen.

Go Up