Go Down

Topic: Arduino Serial Ports for SainSmart Arduino Mega ATmega1280 (Read 684 times) previous topic - next topic

kgriendling

Hello,

I am trying to get my SainSmart development board for Arduino ATmega1280 running and I am having some trouble getting it running. It doesn't seem to find an appropriate serial port as my Arduino UNO does. I have tried downloading Arduino 1.0 as it says on another post on this forum but I think I am all out of other avenues to trouble shoot. I hear it could be a driver issue as well, but no one has linked a place to find appropriate drivers.

I am using Arduino 1.0/1.0.1 on Mac OSX Snow Leopard.

Any ideas for why an applicable serial port is not showing up when I hook up my board?

Thanks,

Kevin

Nick Gammon

Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

kgriendling

http://www.sainsmart.com/sainsmart-mega-1280-mega1280-atmega-avr-development-board-usb-cable-atmel-mcu.html

This is it here.

Nick Gammon

I suspect you need a different driver, however I can't find any links to one, nor can I find any post that agrees or disagrees with that idea.

Strangely, the Sainsmart forum gives no hits if you search for "usb" or "driver" which is hard to believe.

See if it shows up in the USB section of the System Report. My Mega2560 looks like this:


Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

kgriendling

I have listed:

FT232R USB UART
Apple Internal Keyboard
IR Receiver

BRCM2046 Hub

Built in Isight

Internal Memory Card Reader

I dont think the FT232R is it but that would be the only unknown device showing. I do have the board plugged in and the L LED is flashing with the PWR led on.

James C4S

Since the product page clearly says it uses a FT232 and your computer shows a FT232 when connected, one would make the assumption you need FTDI drivers installed for it work...
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

kgriendling

I must have been reading the page for the 2560. My mistake. Thank you I will try that. I just noticed it is the FTDI usb myself.

Go Up