Pages: [1]   Go Down
Author Topic: Displaytech 64128n  (Read 1145 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi everyone,
i am new with Arduino, but i understand bit in programming and electronics...
I bought Arduino Due and a 64128n display of Dissplaytech.

Following this post
 http://www.javimontero.com/blog/2012/10/displaytech-64128n-st7565-128x64-lcd-in-spi-mode/
i cabled my hw, without chip to reduce the voltage (Due work at 3.3V).

Now i'm trying to run the Hello World example in u8glib library using
U8GLIB_64128N u8g(3, 4, 7, 5,6);
constructor.

The problem it that the display seems not work.
I can't see anything on the display!

Thanks for the help!!!

« Last Edit: January 29, 2013, 05:59:25 pm by grunt » Logged

germany
Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
it seems to me that someoften the missing contrast makes all content of the lcd invisible. So be sure that you are using
-the correct pin for contrast ( I see often pin3, but also 4)
-the correct polarisation at contrast pin (some lcd want positve, some negative). Best thing to find it out by datasheet and avoid wrong polarisation.
-the correct voltage. I see everything from +5V to -15V. if you cant find any datasheet, you may try, but I dont know if one can kill his lcd by wrong polarity or voltage. So when trying, use ever a 10k or 20k resistor in serie to limit the current. I use a voltage regulator with adjustable current, so I can the voltage make very 'weak' by setting to a max. of about 10 or 20 mA.

As long as you cant see anything and cant set the contrast from dark to light, you cant be sure if the lcd is showing anything, so try to clear this point first.
Another thing are the many connection variants I see. So be sure that you use the right one for the lib.
Logged

Just started with Arduino Uno. Am soldering a little longer :-)

Germany
Offline Offline
Edison Member
*
Karma: 100
Posts: 1241
If you believe something is right, you won't see what's wrong (David Straker).
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi
This display has its internal charge pump. It does not require any other voltage than 0V (GND) and 3.3V attached to it.

But the problem is, that U8glib has not been ported to the Due as of now (http://code.google.com/p/u8glib/issues/detail?id=141). I simply do now own this board.

Oliver

Logged

Germany
Offline Offline
Edison Member
*
Karma: 100
Posts: 1241
If you believe something is right, you won't see what's wrong (David Straker).
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi
I have added a pre-release of U8glib on the download page: http://code.google.com/p/u8glib/downloads/list
This includes support for SW SPI on the Arduino Due.



Oliver
Logged

Pages: [1]   Go Up
Jump to: