Go Down

Topic: Leonardo on windows 7 - 64 bit - issue on Sperial - driver bug ? (Read 996 times) previous topic - next topic

92Vinc

Jan 29, 2013, 02:39 pm Last Edit: Jan 29, 2013, 02:41 pm by 92Vinc Reason: 1
Hello,

I recently acquired an Leonardo bord. I installed the IDE on windows 7, 64 bits. I had some trouble but I could solve it using your forum, by installing the Arduino version 1.03.

Now I can compile program, download, and execute.

I have somme issue when I want to Serial.Print for debug purpose.
- Serial Read work ok, (and the Rx Led blink)
- Serial Print Always fail (the Tx led always off)

The documentation of if(Serial) recommend the following fr the Leonardo :
while (!Serial) {
   ; // wait for serial port to connect. Needed for Leonardo  
          only
 }

But the program keep looping and the Serial. The Serial always return false, even with the Serial monitor open.

In the Forum, topic http://arduino.cc/forum/index.php?topic=110942.0 says the following :
I finally got it working, after reading a large number of postings. The issue is with the DTREnable and RTSEnable properties set to false, they need to be set to true, even though there is no handshake (HandShake: none), the virtual port requires this to trigger the data retrieval.

To test it, I tried to use a simple emulation terminal (putty) instead of the Serial Monitor of the IDE.
I could not open the COM9 port (the one used by Arduino at the insall). And in my case, even the Werial monitor does'nt not work.

I suspect a configuration problem on serial USB driver.
May be a hardware issue (also the communication to download works fine)

What's your suggestions ?

Thanks.
Vincent

92Vinc

Hello,

That's me again.
I fact I was nt using putty properly. Now it's word OK with Putty.

So the problem does'nt come for the driver or the harware which are ok.

There is syply a bug on the Arduin IDE "erial monitor" which does'nt behave properly on the Leonardo uder windows 7, 64 bits.

Thanks and regards,

Vincent

psbran

Hi. I have same exact problem with Arduino Micro, which I understand works much like the Leonardo.

I can monitor Serial with Putty, but not with Arduino Serial Monitor.

While Putty works, it's a bit painful when I am frequently restarting a sketch.

I'm running Windows 7 Professional, 64-bit.

Did you find a resolution?'

Patrick

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy