Pages: [1]   Go Down
Author Topic: Arduino Due software (1.5.1) on OSX won't launch (resolved)  (Read 2014 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am unable to launch the 1.5.1 IDE for OSX on my MacBook Pro, which I want
to do in order to use a new Arduino Due.

Mac OSX 10.5.8
$ java -version
java version "1.5.0_30"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_30-b03-389-9M3425)
Java HotSpot(TM) Client VM (build 1.5.0_30-161, mixed mode, sharing)

I tried Java SE 6 as well, no help.

I tried using "control click" and open, no help.

I tried moving the icon in and out of my Applications folder.

My older version of Arduino (1.0.1) works fine (I have renamed it ArduinoOld and moved it out of my Applications folder).

I don't have any default hardware folders (that I can find).

On the console i get this message, which I don't know how to interpret:
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865] [JavaAppLauncherError] CallStaticVoidMethod() threw an exception
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865] Exception in thread "main" java.lang.NoClassDefFoundError: javax/swing/filechooser/FileNameExtensionFilter
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865]  at java.lang.Class.forName0(Native Method)
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865]  at java.lang.Class.forName(Class.java:242)
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865]  at apple.launcher.LaunchRunner.loadMainMethod(LaunchRunner.java:56)
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865]  at apple.launcher.LaunchRunner.run(LaunchRunner.java:112)
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865]  at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
> 1/30/13 5:18:33 PM [0x0-0x34034].cc.arduino.Arduino[865]  atapple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java: 52)
> 1/30/13 5:18:33 PM com.apple.launchd[134] ([0x0-0x34034].cc.arduino.Arduino[865]) Exited with exit code: 1

Any suggestions appreciated.
Regards K Lynch
« Last Edit: February 06, 2013, 11:28:20 pm by klynchARD » Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 631
Posts: 34488
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I don't have any default hardware folders (that I can find).
Have you looked in
Documents -> Arduinio
the folder is called hardware just above the libraries folder.
If you have it just rename it something else, I rename it "hardware hide"
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yes, thanks, i saw that in another post and looked for it but i don't have any folders named hardware
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 631
Posts: 34488
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

OK what console are you seeing that error message on?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i launched the "Console" application from Applications/Utilities on the MacBookPro, since I didn't have any other diagnostics (the Arduino icon just goes poof and doesn't send any messages).
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


resolved:
--fixed Java so Java SE6 choice pointed to proper directory for CurrentJDK, and
--built explicitly using the github ide file Arduino-ide-1.5.x
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dear Klynchard
Could you please elaborate on your solution as I have the exact issue and I didn't really understand your solution
Logged

Pages: [1]   Go Up
Jump to: