Pages: 1 ... 12 13 [14]   Go Down
Author Topic: testbericht zum WS2812  (Read 26222 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Edison Member
*
Karma: 31
Posts: 2212
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

J3RE und Carsten, bei den NTs müsst ihr aufpassen! Hier liegen die Anschlussklemmen für Netzspannung 230V offen. Da muss nur die Frau mal eben mitte Finger drankommen! Die Teile haben an den Seiten so wie ich das sehe Öffnung zur Montage. Bau dir da einen gescheiten Rahmen drum, am besten eine komplett geschlossene Box, die nur beim Mesh offen ist,.
Logged

Kein technischer Support über die Private Nachricht!

Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Das werde ich wohl machen, und zur Sicherheit  den Input nochmal mit Heißkleber drüber.
Die wahrscheinlichkeit das was passiert ist zwar gering, aber das Risiko will ich dann nicht eingehen wollen.

Schätze ich werde mal schauen ob Conrad PVC-Boxen in der Größe vorrätig hat smiley


Hoffe ja das das ganze noch klappt, dieser Forumseintrag hört sich nicht allzu optimistisch an, weiß jemand mehr?

https://www.adafruit.com/forums/viewtopic.php?f=47&p=202663

Ich habe das dumpfe gefühl das ich am Ende auch mit dem Arduino nicht das gewünschte Ambilight zu Stande kriegen (zumindest mit dem Nano smiley-sad )

Schätze am Ende wirds doch noch so weit kommen, das ich die WS2801-Streifen kaufen muss....


PS. Beim Test heute habe ich nebenbei die Masse nicht auch am Arduino angesteckt (nicht genug female-female jumper gehabt smiley-grin)
Und konnte kein flackern bemerken smiley



Schöne Grüße
« Last Edit: February 08, 2014, 11:15:55 pm by CarstenW » Logged

Germany, Dresden
Offline Offline
Sr. Member
****
Karma: 14
Posts: 389
30 Jahre Elektronikbastelei, Programmieren null Ahnung!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Guck dir mal dieses NT an:
http://www.pollin.de/shop/dt/NTc4ODQ2OTk-/Stromversorgung/Netzgeraete/Festspannungs_Netzgeraete/Hutschienen_Schaltnetzteil_MEANWELL_MDR_60_5_5_V_10_A.html
Bzw. so ziemlich jeder Bastler hat doch ein ATX Netzteil aus dem PC rumliegen. Auch das kann man recht easy zur Zusammenarbeit überreden  smiley-cool
http://logbuch.dmaertens.de/hardware/pc-netzteil-kurzschliessen
Da muß man nur aufpassen, wieviel die 5V Rail liefern kann (Typenschild)

Gruß Gerald
Logged

rot ist blau und Plus ist Minus

Wien
Offline Offline
Edison Member
*
Karma: 27
Posts: 1849
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,

Quote
Und die nächste Frage, gibts hier irgendwo einen Thread (von mir aus auch im englischen Forum) der sich mit dem nutzen von den WS2812B Streifen mit Adalight beschäftigt, würde das ganze Projekt in nicht allzuferner Zeit fertigzustellen wollen

hier geht's genau darum:
http://forum.arduino.cc/index.php?topic=201134.0

gruß stefan
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ich stehe gerade vor folgendem Problem:

Ich habe an ein SEDU-Board einen WS2812B-Streifen angeschlossen und jedes Mal wenn ich den USB-Stecker ziehe, wird der erste Pixel zerstört (der winzige Controller in der LED hat ein Luftbläschen über sich :-/ ).
Weiß jemand woran das liegen könnte?

Ich vermute, es liegt an der Verkabelung des Ganzen: Der Streifen ist sowohl an Ground und +5V des Steckernetzteils als auch an Ground und Data des SEDU-Boards (welches über USB versorgt wird) angeschlossen. Auf dem SEDU läuft übrigens die tpm2 -> WS2801 Firmware.
Wenn man zuerst das Steckernetzteil zieht, passiert glaube ich nichts. Kann es sein dass sich da ein Kondensator entlädt und so die WS2812B zerstört?

Ich wäre für jede Antwort dankbar, so langsam gehen mir die Pixel aus
Logged

Germany, Dresden
Offline Offline
Sr. Member
****
Karma: 14
Posts: 389
30 Jahre Elektronikbastelei, Programmieren null Ahnung!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Klare Sache, du schickst Daten an den WS2812, wenn keine Versorgungsspannung anliegt. Damit ist dessen Eingang nicht mehr Hochohmig, wie normal, sondern dessen ESD-Schutzdioden werden durchlässig und es fließen recht hohe Ströme. Dann gibt der Schwächere nach. Entweder der treibende Ausgang, oder in diesem Fall eben der Eingang. Hänge mal zwischen Arduino Ausgang und den WS2812 einen 4,7K Widerstand. Damit bekommst du maximal ganz knapp über 1mA bei 5V hin. Bei einem CMOS Eingang sollte das kein Problem mit den Umladeströmen und der Taktgeschwindigkeit sein. Nach Einfügen des Widerstandes solltest du mal diesen Fall mehrmals provozieren. Berichte mal  smiley

Gruß Gerald
Logged

rot ist blau und Plus ist Minus

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 251
Posts: 21270
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Auf dem SEDU läuft übrigens die tpm2 -> WS2801 Firmware.
Das Interface des WS2811/WS2812 ist nicht kompatibel mit dem Interface des WS2801. Ein WS2812 Streifen müßte gar nicht ansteuerbar sein.

Ich habe keine Ahnung wieso die Leds kaputtgehen. Du solltes mal bei http://www.sedu-board.de/sedu-faq/ nachfragen oder über Email http://www.sedu-board.de/impressum/

Grüße Uwe
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 251
Posts: 21270
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Klare Sache, du schickst Daten an den WS2812, wenn keine Versorgungsspannung anliegt. Damit ist dessen Eingang nicht mehr Hochohmig, wie normal, sondern dessen ESD-Schutzdioden werden durchlässig und es fließen recht hohe Ströme. Dann gibt der Schwächere nach. Entweder der treibende Ausgang, oder in diesem Fall eben der Eingang. Hänge mal zwischen Arduino Ausgang und den WS2812 einen 4,7K Widerstand. Damit bekommst du maximal ganz knapp über 1mA bei 5V hin. Bei einem CMOS Eingang sollte das kein Problem mit den Umladeströmen und der Taktgeschwindigkeit sein. Nach Einfügen des Widerstandes solltest du mal diesen Fall mehrmals provozieren. Berichte mal  smiley

Gruß Gerald


So klar ist mir das nicht, denn mach Beschreibung von Raymond75 passierrt es wenn er die Stromversorgung des Steuerbords (Ausgang) abschaltet und die Versogungsspannung des LED-Streifen an ist.

Quote
.. und jedes Mal wenn ich den USB-Stecker ziehe, wird der erste Pixel zerstört (der winzige Controller in der LED hat ein Luftbläschen über sich :-/ ). ...
...Der Streifen ist sowohl an Ground und +5V des Steckernetzteils als auch an Ground und Data des SEDU-Boards (welches über USB versorgt wird) angeschlossen. ...
...Wenn man zuerst das Steckernetzteil zieht, passiert glaube ich nichts. ...

Einen Widerstand zwischen Steuerboard und LED-Strips einfügen ist sicher einen Versuch wert.
Grüße Uwe
Logged

Offline Offline
Edison Member
*
Karma: 31
Posts: 2212
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich grab den Thread hier noch einmal wieder raus. Habe ein Anliegen was die WS2812B betrifft.
Mir ist immer noch nicht 100% bewusst, was wirklich visuell dem Auge am ehesten nach Fading betrifft.

Im Mikrocontroller.net gibt es dazu ja eine endsprechende Diskussion

Ein direktes betrachten der WS2812B halte ich hier aus überflüssig, da diese doch meist mehr als passives Licht genutzt werden.

Gibt es eurerseits bereits Erfahrungsberichte?

Ich habe ein paar Tabellen bereits versucht.
Interessant ist ein sauberes Fading für einen Sekundenzeiger (-> Equinox).

Bin mit der linearen Kurve derzeit sehr zufrieden.


Code:
// linear
const uint8_t fade[32] =
{
7,15,23,31,39,47,55,63,
71,79,87,95,103,111,119,127,
135,143,151,159,167,175,183,191,
199,207,215,223,231,239,247,255
};
//log
const uint8_t fade[32] =
{
20,22,24,26,28,30,33,36,
39,42,45,49,54,58,63,69,
74,81,88,95,103,112,122,132,
144,156,169,184,199,216,235,255
};
//linear+20
const uint8_t fade[32] =
{
20,28,35,43,50,58,65,73,
81,88,96,103,111,119,126,134,
141,149,156,164,172,179,187,194,
202,210,217,225,232,240,247,255
};
Logged

Kein technischer Support über die Private Nachricht!

Pages: 1 ... 12 13 [14]   Go Up
Jump to: