Go Down

Topic: [RISOLTO] Problema Bootloader (Forse) Arduino Nano V3 (Read 972 times) previous topic - next topic

salvob

Feb 01, 2013, 06:22 pm Last Edit: Feb 02, 2013, 06:43 pm by salvob Reason: 1
Salve ragazzi,

mi hanno regalato un arduino nano v3 solo che non riesco a fare l'upload dello sketch.

Ho un mac ed ho dovuto installare i FTDIUSBSerialDriver se no non riconosceva la seriale, mentre con l'arduino Uno la riconsoceva correttamente.

Ho provato a selezionare tutti i tipi di Board, dall'Arduino Uno alla Arduino Pro, ma niente, mi lampeggia il led RX del Nano per qualche secondo e poi da errore (avrdude: stk500_recv(): programmer is not responding)

Potrebbe essere colpa del bootloader? Forse è senza?

Ho provato l'editor versione 1.0.3 e versione 022




leo72

La scheda viene sicuramente venduta con il bootloader preinstallato.
Per programmarla dice di scegliere
Quote
"Arduino Diecimila, Duemilanove, or Nano w/ ATmega168" or "Arduino Duemilanove or Nano w/ ATmega328"

a seconda che tu abbia o la versione con il 328 o con l'168.

Ma il sistema te la riconosce, una volta collegata?
La Nano usa un chip FT232 per la comunicazione, quindi i driver ti servivano perché esso è diverso dal chip della UNO

salvob


C'è scritto Atmel MEGA328P sul microcontroller, quindi "Arduino Duemilanove or Nano w/ ATmega328"

appena inserisco l'usb l'IDE mostra le due porte /dev/tty.usbserial-AH01KOHN e /dev/cu.usbserial-AH01KOHN
Quindi sembra riconoscere la seriale.

Appena premo il pulsante per l'upload, lampeggia per qualche istante il led RX e poi dopo 1-2 secondi 
avrdude: stk500_recv(): programmer is not responding


leo72

Parliamo ovviamente di un Nano originale, giusto?

Lo hai provato su un PC con un diverso SO? Magari è solo una questione di riconoscimento e/o di permessi per scrivere sulla periferica.

salvob

Penso sia un clone

Ho provato in un pc con Windows 7 è da lo stesso problema.

Considerando che la RX sull'Arduino lampeggia, vuol dire che comunque qualcosa la riceve no? Solo che non risponde, forse per questo la TX rimane spenta?

leo72


Penso sia un clone

"Pensi"? O lo è o non lo è. Dove lo hai comprato?
Se non è originale, potrebbe darsi tutto, anche che non ha il bootloader sul chip.
Se hai un altro Arduino, perché non provi a riscrivercelo?

Quote

Considerando che la RX sull'Arduino lampeggia, vuol dire che comunque qualcosa la riceve no? Solo che non risponde, forse per questo la TX rimane spenta?

Probabile.

salvob


leo72


Risolto riscrivendo il bootloader!

Quindi in buona sostanza era un clone senza bootloader.

Go Up