Go Down

Topic: [RISOLTO] Ethernet shield e modem, problemi strani... (Read 2043 times) previous topic - next topic

matrix77

#15
Feb 01, 2013, 04:56 pm Last Edit: Feb 01, 2013, 05:05 pm by matrix77 Reason: 1
Riporto per correttezza i parametri dello shield:

IPAddress ip(192,168,0,20);
IPAddress gateway(192,168,0,1);   
IPAddress subnet(255, 255, 255, 0);

Dimenticavo di dirti che avevo fatto altre prove, come riabilitare il DHCP e inserire il MAC nella lista prioritaria all'interno del modem, con tanto di associazione dell'indirizzo IP.

BrainBooster

si, non si mettono daccordo sulla velocità didialogo il router vorrebbe andare almeno a 100Mb se possibile, mentre lo shield  conosce solo i 10Mb (e non  sono  negoziabili).
L'implementazione dell'autonegoziazione della velocità è nel firmware  del router, e nonostante ci siano degli standard su come fare questa cosa, ogni produttore fà un pò il cacchio che vuole...
L'interposizione di un terzo dispositivo in grado di fare  meglio questa cosa avolte  risolve (basta uno switch) 

matrix77


si, non si mettono daccordo sulla velocità didialogo il router vorrebbe andare almeno a 100Mb se possibile, mentre lo shield  conosce solo i 10Mb (e non  sono  negoziabili).
L'implementazione dell'autonegoziazione della velocità è nel firmware  del router, e nonostante ci siano degli standard su come fare questa cosa, ogni produttore fà un pò il cacchio che vuole...
L'interposizione di un terzo dispositivo in grado di fare  meglio questa cosa avolte  risolve (basta uno switch)  

Bravo!, non ci avevo pensato a questa cosa, mi dai una dritta su quale modem acquistare, visto che tra un po' questo N300, volerà dalla finestra :smiley-sweat:?

BrainBooster

no, purtroppo è roulette russa...
Prova semplicemente a mettere fra il modeme lo shield uno switching hub qualsiasi, prima di provare altro.
L'N300 non è maleper il resto.

matrix77


no, purtroppo è roulette russa...
Prova semplicemente a mettere fra il modeme lo shield uno switching hub qualsiasi, prima di provare altro.
L'N300 non è maleper il resto.

Ok dai, mi rode avere due dispositivi collegati, quando uno potrebbe funzionare tranquillamente.Ricollegherò quel vecchio dlink router, ma che scocciatura però, immagino che anche l' hardware dello shield, sia "rigido" da quel punto di vista e che quindi le velocità non siano gestibili da sketch?

matrix77

Grazie mille comunque BrainBooster, adesso quasi quasi, vado a prendere uno switch, almeno è più piccolo del router eheh

BrainBooster

non c'è di che :)
se non altro uno switchino a 4porte è meno visibile, inoltre qualche porta in più serve sempre

matrix77


non c'è di che :)
se non altro uno switchino a 4porte è meno visibile, inoltre qualche porta in più serve sempre

Si hai ragione!, faccio una volata, poi ti aggiorno, buona serata e grazie ancora per la disponibilità.

Go Up