Pages: [1]   Go Down
Author Topic: How I solved my CP2102 USB to UART problems for a breadboard Arduino  (Read 2244 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had put together a breadboard version of an Arduino Uno, and the first problem I had was installing the drivers for my CP2102 USB to UART device.

Solution to that problem: I eventually found, downloaded, and installed the driver from here: http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

After that, I was able to get the Blink sketch uploaded and was happy to see that everything seemed to be working. But, something important came up, and I had to put all my hobby stuff away for the day. I came back to it a few days later, and I was about to go insane because I could not upload anything. Kept getting those annoying sync errors.

Solution to that problem: I disconnected my power supply and connected the USB power from the bridge. (I actually had it wired that way when I installed the correct driver, but I didn't know at the time that this was necessary.)

Everything is just dandy now. Uploading sketches is no longer a problem.

So, I'm not so sure what might be wrong with my normal method of providing power to the board, but it turns out that the USB to UART bridge only works when I have my board power coming from the bridge. Anyone know why this is necessary?
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 208
Posts: 12929
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Anyone know why this is necessary?

Forgot to connected the grounds?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hello can you post you bread board version ?
i keep getting this
avrdude: stk500_getsync(): not in sync: resp=0x00
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,
might be because of any 1 of the reasons
you may not selected the proper board. i am having  arduino uno board. so i will choose (tools->boards->arduino uno).
you may not selected proper serial port. i connected to ( PORT ) com8. so i will select(tools->serial ports->com8).
you might not installed proper driver software. so go to (control panel->device manager->ports) if u can find audrino there install it.
if you found some thing else install the driver software then. i am  using a printer cable so it will show like cp210x USB to UART bridge. i used the prev link which cooper shared to download driver for UART.
once this is done. you can connect your board and try .
Logged

Pages: [1]   Go Up
Jump to: