Go Down

Topic: odd FTDI problem (Read 1 time) previous topic - next topic

knuckles

hi
i have aquired a FTDI board (silab CP2102 on board ) off chinabay and hooked it up to a sparkfun pro micro 328 and a Xino Uno clone and everything is fine when programming examples
typically i connect Tx ,Rx ,5V and Grd ,and DTR via a cap to reset on the board .
so far so good ...

now, when i use this setup on a genuine UNO it does not work at all.
any ideas why it wont work ?


knuckles

i saw a reference to a pull up 10k resistor to 5v after the cap ,wonder if that will do it ?

knuckles

i tried a sparkfun FTDI basic board to load on sketches  but still its the same .it will load onto a pro micro or Xino clone but it wont load a sketch onto a UNO . (2 UNO boards have been tried)
thats using Rx to Tx ,Tx to Rx ,V and Grd and DTR via a cap to reset .

knuckles

i tried a 10k pull up resistor after the cap but still no loading of a sketch :smiley-sad-blue:

CrossRoads

Why are you connecting a USB/Serial adapter to a board that already has one installed (uno)? What is it you're trying to do?

CP2102 board is not an FTDI board - FTDI board will have an FT232RL chip, like the older Duemilanove boards.
Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Go Up