Pages: [1]   Go Down
Author Topic: invalid device signature on attiny85  (Read 445 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 3
Posts: 188
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I've no idea why I get this error:

Code:
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

I've checked all the connections using a continuity test, so I am a bit confused. I have ISP sketch uploaded to board correct bored selected (attiny85) and arduino set as ISP. anyone know what else might cause this? It was working perfectly yesterday...

wasn't either of these as well: http://arduino.cc/en/Guide/troubleshooting
« Last Edit: February 23, 2013, 03:33:04 pm by hilukasz » Logged

for(i = 0, i < 820480075, i++){ Design(); Code(); delay(1000); } // hellowoo.com

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 201
Posts: 8661
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If you turn on verbose upload logging you will get to see the the signature that is read and the signature that is expected.

If the signature being read is 0x000000 or 0xFFFFFF then something isn't working in the SPI interface.  Perhaps the chip fuses have been set to disable reset, disable serial programing, or require an external crystal for the system clock.
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Offline Offline
Full Member
***
Karma: 3
Posts: 188
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

reseting the fuses seemed to have worked. thanks!
Logged

for(i = 0, i < 820480075, i++){ Design(); Code(); delay(1000); } // hellowoo.com

Pages: [1]   Go Up
Jump to: