Pages: [1]   Go Down
Author Topic: Using the UNO with XBEE and X-CTU on Linux  (Read 546 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 1
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the Arduino installed and operating as expected on a Linux (Ubuntu 12.04) PC.
 I installed X-CTU (using WINE) and that works ok but not with the Arduino UNO board.
I recently purchased a XBEE shield but I am unable to get X-CTU to connect with the comm port.
I tried all of the combinations including removing the ATMega328 from the board.

Interesting enough, I can access the XBEE data using a simple terminal program. I am not sure why
the X-CTU application can not connect using the same port that is used by the terminal program.

The one thing not attempted yet is to try it on my XP PRO using windows.

I am hoping someone can point out the errors of my ways and I can then use the Linux PC. smiley-eek-blue
Thanks in advance.

Logged

Seattle, WA USA
Online Online
Brattain Member
*****
Karma: 613
Posts: 49257
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

X-CTU is designed to program the XBees. As a terminal application to talk to the XBee it is woefully inadequate. Why do you want to use it?
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am interesting in using X-CTU to program the XBEE modules, that is what is not working.
I mentioned that using a terminal program that I can access the module but not using X-CTU.
Logged

Pages: [1]   Go Up
Jump to: