Pages: 1 [2] 3   Go Down
Author Topic: PWM-Signal  (Read 5235 times)
0 Members and 1 Guest are viewing this topic.
Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 248
Posts: 21153
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Zum Effektivwert:
Der Effektivwert ist der quadratische Mittelwert der Wechselspannung.
Oder einfacher gesagt: Eine Gleichspannung die die gleiche Wärmeleistung erzeugt wie die Wechselspannung ist deren Effektivwert.

Der Arduino hat standartmäßig eine PWM-Frequenz von ca 490Hz.

Grüße Uwe
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 287
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Die einfachen Gesetze ,wie das Ohmsche, behersche ich einigermaßen.

Ich habe ein Arduino Mega 2560. Ich hab online gelesen das alle PWM pins eine frequenze von 490 Hz haben ,außer pin 4 und 13 die haben eine frequenz von 980 Hz( also fast 1KHz)
Nun habe ich es am pin 13 versucht und es hat nichts bewirkt. Ich komme einfach nicht über 180 V.

Muss ich die Frequenz des PWM signals erhöhen? Wenn ja, wie geht das?

Was ich auch nicht verstehe ist warum bei PWM signal 255 kein Mittelwert von 5V erreicht wird bei mir, sondern 4,3V . Laut der abbildung im link sind doch bei 255  permanent 5V gegeben.
http://arduino.cc/en/Tutorial/PWM
Logged

Gruß

strohhirn

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 248
Posts: 21153
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Was ich auch nicht verstehe ist warum bei PWM signal 255 kein Mittelwert von 5V erreicht wird bei mir, sondern 4,3V . Laut der abbildung im link sind doch bei 255  permanent 5V gegeben.
http://arduino.cc/en/Tutorial/PWM
Miß mal die 5V des Arduino.
Grüße Uwe
Logged

Germany
Offline Offline
Full Member
***
Karma: 3
Posts: 126
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Strohhirn,

Quote
Was ich auch nicht verstehe ist warum bei PWM signal 255 kein Mittelwert von 5V erreicht wird bei mir, sondern 4,3V . Laut der abbildung im link sind doch bei 255  permanent 5V gegeben.

Ergänzend zu den Anmerkungen von Uwe:
Versorge mal probehalber den ARDUINO über ein Steckernetzteil, evtl. kommst Du dann schon näher an die 5V.
Bei meinen Boards habe ich auch 'nur' 4,8V zur Verfügung, allerdings weiß ich nicht, wie genau mein Multimeter ist.

Du solltest auch mögliche Messfehler Deines Messgerätes in Betracht ziehen.
Die niedrigen Spannungsbereiche kannst Du mit einer Silberoxidzelle (Knopfzellen z.B. SR44) überprüfen.
Dieser Typ von Batterie hält sehr stabil 1,55V und wurde deshalb auch früher in Belichtungsmessern von Kameras benutzt.
Alkalische oder Lithiumzellen gehen nicht, die haben nicht die erforderliche Spannungskonstanz!

Evtl. hat ja auch Dein Elektrikerkollege eine hochgenaue Spannungsquelle für solche Zwecke zur Verfügung oder kann eine Vergleichsmessung mit einem kalibrierten Messgerät machen.

Sollte das alles auch nicht zum Ziel führen, wäre wirklich zu überlegen, ob Du die KEMO-Module nicht evtl. zurückgeben kannst und dann, wie weiter oben angesprochen, eine einfache Zweipunktreglung (mit einstellbarem Sollwert und ggf. einstellbarer Hysterese) machst.
Das ganze kannst Du ja dann später noch erweitern, mit Schaltuhrbetrieb, Nachtabsenkung usw..


Grüße

Martin
 
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 287
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Miß mal die 5V des Arduino.
Hab ich gemacht sind nur 4,7V , aber trotzdem ist das je mehr 4,3V.

Quote
Du solltest auch mögliche Messfehler Deines Messgerätes in Betracht ziehen.
Ich habs versucht. Da ich aber keine ahnung hab in welchem Gerät(außer dem bellichtungsmesser) ich so eine Silberoxidzelle finde habe ich aus einer kleinen mini Taschen LED eine 3V Knopfzelle rausgeholt(Henli Max,  CR 1220, 3V, CZYF). Dort habe ich 2,91-2,92V gemessen.

Hab ein 8,5V(gemessen 10,7V) Netzteil angeschlossen. Und es hat die Spannung bei 255 nicht geändert.
Wieso ist die Spannund bei 5V (gemessen 4,7V) mehr als beim PWM signal 255, also 4,3V?

Kann ich nicht irgend wie die Spannung erhöhen?
Jetzt mal ne ganz dumme Frage, kann man mit einem Transistor den Mittelwert um 0,2-0,7V erhöhen?
Logged

Gruß

strohhirn

Germany S-H
Offline Offline
Faraday Member
**
Karma: 134
Posts: 2849
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

wenn ich das PWM signal 255 gebe und denn den Strom bei der heizung messe steht da nur 180V statt 220V.

Laut Datenblatt sollst Du aber gar nicht 100% PWM auf den Eingang geben, um 100% Leistung zu erreichen.
Im Datenblatt lese ich:

Impulsbreite 10...90 % PWM. Mit der Impulsbreite 10...90 % wird die Leistung eingestellt
10 % TTL PWM ==> Leistung: „0“
50 % TTL PWM ==>  Leistung: ca. 50 %
90 % TTL PWM ==>  Leistung: ca. 100 %

Hast Du denn auch mal 90% PWM ausprobiert, also den Wert 0,9*255 = 229 oder 230 für die PWM?

Hast Du an Deinem Arduino auch einen der schnelleren Fast-PWM Pins verwendet? Meines Erachtens arbeiten die nicht alle mit der vom Modul geforderten Mindestfrequenz von 1 kHz, sondern etliche Arduino PWM-Pins sind nur halb so schnell bei ca. 0,5 kHz.
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 287
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Ich habe ein Arduino Mega 2560. Ich hab online gelesen das alle PWM pins eine frequenze von 490 Hz haben ,außer pin 4 und 13 die haben eine frequenz von 980 Hz( also fast 1KHz)
Nun habe ich es am pin 13 versucht und es hat nichts bewirkt. Ich komme einfach nicht über 180 V.

Und bei 230 messe ich auch nur 180V.
Logged

Gruß

strohhirn

Germany S-H
Offline Offline
Faraday Member
**
Karma: 134
Posts: 2849
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Und bei 230 messe ich auch nur 180V.

Den Hinweis "Die Kabel zwischen dem Ansteuermodul M150 und dem Leistungsreglermodul können max. 1 m lang sein." hast Du auch beachtet?

Und Du hast auch wirklich nur eine Heizung oder Glühlampe angeschlossen, rein ohmsche Last, und da ist garantiert keine eigene Regelelektronik drin, weder zum Dimmen, Heizleistungsändern oder Sanfteinschalten, sondern nur eine Heizwendel?

Und wieviel Watt zieht die angeschlossene Heizung eigentlich aus dem Modul, während Du die 180V mißt, bzw. welche Nennleistung als Verbraucher hast Du angeschlossen, während Du misst?

« Last Edit: February 08, 2013, 05:31:43 am by jurs » Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 287
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Den Hinweis "Die Kabel zwischen dem Ansteuermodul M150 und dem Leistungsreglermodul können max. 1 m lang sein." hast Du auch beachtet?
Das Kabel ist bei mir auf jeden Fall keinen Meter lang.(ca. 20 cm)

Quote
Und Du hast auch wirklich nur eine Heizung oder Glühlampe angeschlossen, rein ohmsche Last, und da ist garantiert keine eigene Regelelektronik drin, weder zum Dimmen, Heizleistungsändern oder Sanfteinschalten, sondern nur eine Heizwendel?

Ich habe zum Testen eine Glühlampe angeschlossen. Da ist keine weitere Regelelektronik auser dem M150 angeschloßen. Alles ist ohne zwischenteile ,wie Wiederstände, Kondensatoren ..., mit einander verbunden, wie im Datasheet dezeigt.

Quote
Und wieviel Watt zieht die angeschlossene Heizung eigentlich aus dem Modul, während Du die 180V mißt, bzw. welche Nennleistung als Verbraucher hast Du angeschlossen, während Du misst?
Die Heizung(3 kW) hat einen Wiederstand von 16 Ohm , somit beträgt die Leistung der Heizung ,bei 180V, 2025W . (Errechnet)
Logged

Gruß

strohhirn

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 248
Posts: 21153
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Die Heizung(3 kW) hat einen Wiederstand von 16 Ohm , somit beträgt die Leistung der Heizung ,bei 180V, 2025W . (Errechnet)

Unabhängig von der gemessenen maximalen Spannung:
Das M28 Modul ist max für 12A spezifiziert. Bei 230V sind das 2600 VA oder bei ohmschen Verbrauchern 2600W. Eine 3KW-Heizung ist zuviel für das Modul.
Grüße Uwe
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 287
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ja aber ich hab dieses Modul doch schon 1 Jahr mit einem Poti im betrieb und da funktioniert alles wunderbar.
Ich möcht doch nur diesen poti durch diesen M150 ersetzen.

Noch mal die Frage: Würde es was bringen nen kleinen Transistor anzubringen, der den Mittelwert um 0,2- 0,7V erhöht?
Logged

Gruß

strohhirn

Germany S-H
Offline Offline
Faraday Member
**
Karma: 134
Posts: 2849
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ja aber ich hab dieses Modul doch schon 1 Jahr mit einem Poti im betrieb und da funktioniert alles wunderbar.
Ich möcht doch nur diesen poti durch diesen M150 ersetzen.

Wenn das Gerät durch die bisherige Überlastung mal nicht schon einen Schaden weg hat, und genau deshalb nicht mehr auf maximale Leistung kommt, weil schon die teilweise innerliche Zerstörung bzw. vorzeitige Alterung der Halbleiterelemente durch Überhitzung/Überlastung stattgefunden hat.
Logged

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 248
Posts: 21153
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ja aber ich hab dieses Modul doch schon 1 Jahr mit einem Poti im betrieb und da funktioniert alles wunderbar.
Ich möcht doch nur diesen poti durch diesen M150 ersetzen.

Noch mal die Frage: Würde es was bringen nen kleinen Transistor anzubringen, der den Mittelwert um 0,2- 0,7V erhöht?

Bei einem PWM Signal ist nicht die Spannung maßgebend. Das PWM Signal wird ja als solches erkannt und Du kannst das Modul in gewissen Grenzen regeln.

Laut dem bisher gesagten ist die Ansteuerung schuld.

Has Du die Spannung an der Heizung mit der Poti-Regelung gemessen? Erreichst Du da 230V?

Grüße Uwe
Logged

Offline Offline
Sr. Member
****
Karma: 8
Posts: 287
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich habe im Netz wo die Heizung steht 240V da das in einem Betriebsgebiet liegt. Wenn ich dort den Poti voll aufdrehe bekomme ich 215 V an der Heizung.

Das sind zwar 25V weniger, reicht aber vollkommen aus.

Deswegen möchte ich zuhause wenigstens über 200V kommen.

Zuhause probiere ich das alles mit einer Glühbirne und anderen brandneuem Kemo Modulen, d.h. da kann nichts kaput sein.

Logged

Gruß

strohhirn

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 248
Posts: 21153
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mißt Du mit dem gleichen Meßgerät?
Grüße Uwe
Logged

Pages: 1 [2] 3   Go Up
Jump to: