Pages: [1]   Go Down
Author Topic: PWM LED stört 433MHz Receiver  (Read 606 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Leute,
ich habe an meinem Arduino Uno einen 433MHz Reciever und eine RGB LED angeschlossen.
Mit dem Receiver empfange ich einen 30 Bit langen Code der die Farbinformationen für die LED enhält.
Soweit funktioniert das System ohne Probleme, nach dem ersten Code jedoch funktioniert der Receiver nicht mehr.
Wenn ich die LED aber von GND trenne und den Code dann nochmal schicke leuchtet die LED in der neuen Farbe.

Ich nehme an das PWM Signal stört irgendwie die den Receiver über GND!?
Hat jemand eine Idee wie ich den Receiver von den Störeinflüssen befreien kann?
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 266
Posts: 21657
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hast Du Vorwiderstände an der LED?
Logged

0
Offline Offline
Faraday Member
**
Karma: 24
Posts: 3487
20 LEDs are enough
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Erst einmal sicherstellen, daß die PWM überhaupt das Problem ist. Was passiert wenn Du das drahtgebunden ansteuerst? Programmierfehler sind ja nicht unbedingt selten.
Logged

Check out my experiments http://blog.blinkenlight.net

Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Zu Uwe:
Ja die 3 dioden sind mit den passenden Vorwiderständen versehen um den strom auf 20mA zu begrenzen.

Zu Udo:
Ohne LED empfängt das Board alle Daten so wie es es soll, schließe ich die RGB-LED an und die PWM-Ausgänge sind auf null kommen auch Daten an, sobald aber die LED in der zuvor übertragenen Farbe leuchtet, ist der Empfang gestört. Ziehe ich dann im laufenden Betrieb die LED raus und sende den Code wieder, leuchtet sie beim einstecken in der anderen Farbe. Meine Vermutung ist daher das der der gepulste Stromfluss sich irgendwie auf den schwingkreis des receivers auswirkt und ich habe leider keine ahnung wie ich das kompensieren kann.
Ich habe bereits versucht einen kondensator parallel zum receiver zu schalten aber das half leider auch nicht!
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 266
Posts: 21657
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Machst Du mal bitte ein Foto von Deinem Aufbau. Danke
Grüße Uwe
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich hab jetzt den "China Receiver" durch einen von Watterott ersetzt und es funktioniert alles wie es soll.
Scheinbar reagiert das gute Stück asiatischer Baukunst sehr empfindlich auf die durch die PWM erzeugten schwankungen.
Wenn interesse besteht kann ich hier ja trotzdem noch aufbau und Quellcode veröffentlichen.
Danke für eure Mühen!
Logged

Pages: [1]   Go Up
Jump to: