Go Down

Topic: Atmel Studios 6 Issues (Read 1 time) previous topic - next topic

nkd5025

Hello Everyone,

I am having the worst possible experience trying to work with atmel studio 6 and am looking for a bit of help.

I am using Atmels avrisp mkII programmer to try and burn the arduino bootloader onto some atmega328P-AU and atmega328-AU chips, I have both.
I am running avr studio 6 on windows 8 beta through VMfusion as I don't have access to any windows machines.

After finally getting atmel studios to connect to the avrisp mkII and update the firmware I tried to read the chips through their isp connection and couldn't get a reading.  I figured that the chips may have been bad due to messing with the avrisp on a mac trying to burn the bootloader through the arduino software so I replaced the chip with a brand new one (Atmega328P-AU).

With the new chip I was able to get a good reading on the chip and everything worked fine, I programed the optiboot into the chips flash and everything was still okay.  I then went to program the fuses to 0xFF LOW 0xDE HIGH and 0x05 Extended.  When I clicked program fuses I received the error "command failed due to previously failed command" then I get a message saying it cannot enter programming mode.  Now I cannot read the at all anymore.  I tried on another atmega328P-AU chip but this time didn't program the bootload, I read the chip, everything was fine, went to set the fuses, same error.

I was successfully able to program an attiny85 chips fuses with no issues whatsoever.

Does everyone have a hard time working with the avrisp mkII, there seems to be a lot of people running into issues with it?
If anyone was any advice on getting this to work it would be much appreciated.

Nick D.

dc42

#1
Feb 06, 2013, 11:48 pm Last Edit: Feb 06, 2013, 11:49 pm by dc42 Reason: 1
I use the avrispmkII with both Atmel Studio and Arduino IDE. I've used it to program and reprogram both atmega328p and attiny45.

Bear in mind that once you program the fuses to require an external clock, you can't program the chip (or even read the device ID or fuses back) unless you have a crystal, ceramic resonator or external clock connected to the chip being programmed.
Formal verification of safety-critical software, software development, and electronic design and prototyping. See http://www.eschertech.com. Please do not ask for unpaid help via PM, use the forum.

nkd5025

I have the chips in circuit with a 16mhz crystal and two 0.1uF caps.  These was in place when I could read the device signatures.  It stopped working the first time I tried to program the fuses. 

I had picked Ext Crystal Osc.; Frequency 8.0- MHZz; start-up time PWRDWN/RESET: 16K  CK/14CK + 65ms;

The programmer didn't even finish programming the fuses so that can't be the problem, correct?  I am trying to read the device at 250KHz and I get nothing.

Thanks for the help!

nkd5025

I think I have found my issue, I apparently ordered series load crystals instead of parallel.  I have a crystal lying around I know is parallel and will try replacing it tomorrow to see if that does it.

nkd5025

Tested it out on an atmega328p dip version and it still failed with the correct crystal in place.  Luckily, I noticed that I had replaced one of the 22pF caps with a 0.1uF cap, which was causing the problem!

Nick D.


Go Up